Vertex level control weight painting?

I am trying to use the weight painting tool on a high poly mesh and finding it highly frustrating, one little slip up and it has sprayed over onto a part of the model not even associated with the bone, worse it is in solid mode, so it sometimes barely touches a cranny and I don’t find out about it until I test the bone, and find a little piece somewhere moving, and i have to rotate to the exact right angle to correct it…

Is there a different way to weight paint… like pick vertices and just give them a weight manually? Or maybe hide parts of the model so you will only be painting the areas that are inthe vertex group?

Alt-B no longer selects loops it is a handy hide everything else feature
Alt-B to take you back out

edit - only works in rectangles
you could hide verts but that would probly be silly - work*2

In the Paint tab in F9 click Wire, then just work zoomed in as close as you can. There’s no way to hide in WeightPaint mode.

%<

?? thats funny Alt-B works for me in weight paint mode

unless your meaning hiding verts yeah I guess that wouldn’t work

Ok, so I painted out a nice rainbow… but when I manipulate the bones, it is still acting like all the vertices have a weight of 1… is there something I forgot to do to apply the wieght paint values?

http://img66.imageshack.us/img66/456/weightpaintingprobs5ue.th.jpg

In F9, Armature tab, make sure you have only Vertex Groups active (Envelopes off), even (especially) if you’re using Envelope type bones.

HatchFactory, sorry man, I didn’t mean to shoot you down. I was on the phone while we were posting and didn’t see your suggestion till I came back, though Alt-B still won’t limit the view to Vertex Groups (or hide them).

%<

Learned that a couple of days ago, so envelopes aren’t on.

Strangely, I have turned the setting down to 0, and yet it is still moving as if they are all assigned a weight of 1…

http://img77.imageshack.us/img77/5561/weightpaintingprob28pc.th.gif

Shift-LMB on a face in WeightPaint mode and see if they’re grouped to another bone?

Wow, I didn’t know about shift-LMB, but unfortunately, it only showed as linked to “thrusters”

In the action editor, there is a row for a vertex group that no longer exists, because I deleted it and the bone, is it possible that is causing a problem?

I reloaded Blender, and it reset the weight for the vertex group to 1 !

have you considered using a b-bone with several segments, that’s probably what I would do.

quick and dirty example weighted about the same

top normal with weights, bottom w/ b-bone segmented into “3”, inside “1” outside “0”

http://img57.imageshack.us/img57/4555/exmple2hd.gif

I need to use as few bones as possible, because this will be ported to a game engine, and I can only use the basic type.

In the action editor, there is a row for a vertex group that no longer exists, because I deleted it and the bone, is it possible that is causing a problem?

Are you sure you didn’t set a shape key that may affect a vertex group?

How owuld I check thta, and how would I delete the “shape key”

Select your object and look at the Shapes tab in F9; if it shows a datablock then you can look for Shapes in the menu. No datablock means no shapes.

%<

No shapes…