Vertex normal and unreal editor

Hey there!

I made this mesh with custom(?) normals, and in blender it gives good results, but if i export it to UE it gives those hard cuts in the shading

The vertex normals are created via Mesh Machine and basically nothing special on the mesh, just lots of transfered normals and a weight normal to the leftovers :stuck_out_tongue:

image

Can You give me any hint, how should i fix there shading errors?

Thank You!

Any blender modifier has to be apllied before exporting to any other format. Ever.

You may also look here:

1 Like

Sadly it’s not working!

As said in this (older) UE thread : it works for him (since you are showing again the modifier… did you applied it? or chekc custom properties? IDK…)
Seams to be that there are multiple ways of annouance (just something complettly different)

But in general: tricks in one engine doesn’t have to work in another… so they have to be made “un-tricky”… i also see some glitches in the chrome material… so you may wanna think about just cleaning the geometry ?? Because Unreal also just support triangles and if some of your quads are non-planar…

yep i applied the modifiers, but i didn’t screenshot the empty modifier list :slight_smile:

i also checked in the Face (smooth) so sadly that is also can’t be the problem

blender_pr_asset_04.blend (2.3 MB)

Please can You export this stuff, maybe there is also something on the mesh that i still don’t catch.

Thank You for the fast reply!

Hmm… there are some thing that do make me wonder:

  • n-gons and quads… when made for a a triangle using gam engine
  • mirror modifier (hops_mirror on Base.002) on a already almost symetrical object (-> overlapping geometry)
  • tweaking normals (made by mesh machine) on … n-gons …?? (has to be transfered onto triangluated)

This is a bit much to ask: for example on the Base.002 applying the modifier weighted normal modifier seams to be okay but checking this for Base.001 … one wheighted, which seams to doesn’t apply good and six normal transfer…

i question that now…

I would think about some more traditional hard surface modelling technics (which have to be be at some mastery level for this) and maybe use a subdived version for normal baking… here is a quick paintover to show some problematic edges wich will disturbe/break the edge flow an produces glitches:

I think “just” tweaking the normals may work in the app in which you does this but on the other hand migrating this trick on this model onto some other app is just a weird worklow…

1 Like

Hey, thanks for the detailed reply!

I tried all the stuff You wrote:
-everything triangulated (“hard” tri, not modifier that applied at export)
-no long triangles (basically almost quad ratios all along the mesh (but triangulated of course: :))
-no mirror modifier used at all
-2 tweaking normals: 1 for the outside of the hole, and one at the “bottom”/flat area.

It works perfectly in blender, and the same sharp cut effect in UE.
btw if i didn’t triangulated at all i’ve got the same effect

“and maybe use a subdived version for normal baking”
This is a so called midpoly model. No highpoly or traditional tangent normal bake, only transfer normals and weight normals + hard edges when it’s necessary.

Please feel free to test, or export the mesh yourself (if You are curious about the solution :D)
vnormal_test.blend (1.5 MB)

Quick note: I used similar technics in other software (modo) and there wasn’t this kind of weird cut effect in the shading.
I’m using blender because of the amazing vertex normal management (no ironic tone here), the highly scriptablity and customizability (via PME), and least but not at last the amazing, supporting community.

My experience with other softwares and how the “baked” custom vertex normal is working is, the (baked) vertex normal itself is highly independet from the topology itself.
Same seems true here (which is a good news because it should supposed to work like this), i cutted, triangulated, even merged vertexes and the baked (transfered) vertex normal not even flickered.
Topology is important because of deformation and silhouette, shadow casting. So triangulating is also important because of those things. If your shading (vertex normal) is live (not baked) then of course topo is crucial.
But midpoly modeling is highly built on custom normals.

This is a bit much to ask: for example on the Base.002 applying the modifier weighted normal modifier seams to be okay but checking this for Base.001 … one wheighted, which seams to doesn’t apply good and six normal transfer…

Sadly Base 002 is also has false shading in UE
Vertex normal on Base 001 seems working fine both in blender and UE, and all the six normal transfers also working fine (or let’s say the same way). The only problem is the same what Base 002 has, that cut shading error

mirror modifier (hops_mirror on Base.002) on a already almost symetrical object (-> overlapping geometry)

How do You mean overlapping geo? If i apply the modifier it simply mirrors one side to the other.
In edit view You see the original mesh yes, but the mirror modifier overwrites that mesh with the mirrored one.
But i tried the export with manually applied mirror modifier, and still has the same result.

Anyhow Thank You again for the reply, because at least i created a cool diagnostic mesh :smiley: so i can close out a lot of thing…
and still don’t know what is the solution :smiley:

Okay maybe i thought more about that traditional hardsurface modelling like:

but also nice to learn someting about those normal transform… have to look a bit more into it…

  1. Make sure you apply scale (rotation isnt necessary) for avoid any possible issue.
  2. You dont need to apply modifiers before export. Its not necessary at all.
  3. Always have Triangulate modifier for everything. Set triangulation to “Keep normal”.
  4. Use the setting below

Blender:

UE:

Real case examples:



I have to apologies!

I’m always doing this :stuck_out_tongue: I closed out most of the modeling issues You mentioned above here, so i took a big walk and then suddenly realised that the freaking UVs are doing these seam errors, because even if i don’t have any texture, the material (shader) is still calculating with tangent and the uvs :stuck_out_tongue:
So as soon as i made an auto uv, all the seams are gone! :stuck_out_tongue:
btw both Okidoki and SoundDifferent gave me very useful hint so i could close out many things :slight_smile:

btw mirroring is affect to the uv, so it can produce shading seams
and the triangulate everything but keep normal is also will be useful when i’m baking from highpoly to lowpoly :slight_smile:

so conclusion:
I set everything as You suggested, and still if You have this thiny sharp shading seam issues along any edges, then check your UV because that can freak out UE
solution in this case: simply make a proper uv with as less seams as You can and You will get perfect shading, and don’t forget to set up what Okidoki and SoundDifferent mentioned (especially SoundDifferent sum it up very clearly)

Thank You again for the fast reply and the detailed info!

And Okidoki
Believe me, You can get reckless with modeling until You don’t want to deform your mesh.
I mean look at this stuff:


it has nice shading (some of the bevels could be nicer and could get more segment)
no seams at all :slight_smile:
And i intentionally didn’t triangulated my mesh just to check how my transfer normals are working.
Also terrible topo. Mesh Machine is one of the best addon if You work with midpoly (or You want to modify your already freezed mesh)
Basically i can modify any part of my object with that puppy, and transfer normal-ing is like a toy in the kindergarden.