Vertex Shaded models - Any way to apply global fx?

I’ve just put the finishing touches to my santa character. Its basically vertex shaded with one texture map for the eyes.

While vertex painting i was switching between 'face select (‘F’) and 'vertex paint (‘V’) and something caused the whole object to be ‘smoothed’ or ‘smudged’…

I dont know how it happened but it would be handy to know if i have stumbled on a ‘global’ vertex smoothing keystroke.

Any idea?

Usually, I like having things smoothed, but it looks like everything gets smoothed if you are in vertex paint mode, but not in face select mode (even with the soft option off). If you want the hard edges, go into vertex paint, then go into face select mode. Select all the faces you want to paint on, and turn off soft (in the edit buttons). Make sure that you don’t paint in only vertex paint mode.

I don’t know why it does that, it seems like it assumes that soft is always on in vertex paint mode.