Vertex Slide Snapping

I have been practicing with vertex sliding/edge slide snapping and am having trouble getting it to work most of the time

In this Exercise I am trying to make Vertex “A2” align with the “Imaginary Straight Line” only by vertex slide snapping. The vertex should snap to the “Imaginary Intercept Point” if this is done correctly. There is multiple settings I have tested but for an unknown reason “A2” always merges with “A3”

I need help figuring this out if this is even possible with blender?

The fastest way I could manage this was by

  1. actually creating the “imaginary straight line” by extruding vertex B2 along the x axis
  2. setting the snapping mode to edge and targeting that line

Yes that did work .thank you. I did not think of that. I just thought that maybe Selected “A2” would be able to snap and slide to other vertices; by copying Z-axis in height while also automatically adjusting X-axis to keep the “A2” & “A3” line straight keeping its original angle formation unchanged. Your instructions stand as a method I suppose to get the job done. I guess I just don’t understand Why “A2” always Merges with “A3” no matter what vertex its being snapped with. Thank you for your Answer

Sorry I might be posting/commenting a lot BlenderArtsitsorg is limiting my communication privileges

MESSAGE 1) I am trying to do something similar on my model. The method you described worked on the exercise. I tested it. “B3” snapped directly to “Imaginary Intercept Point #1” while the “Ring Orb” was hooked on the “A2” & “A3” line

MESSAGE 2) No matter Where I slid the “Ring Orb” “B3” was always locked at "Imaginary Intercept Point #1"Which is great. I am trying to replicate that success in my model.

I am not sure why in my model I am not having success with the same stunt? I am using the same settings I practiced on the exercise. I believe the situation is the same as before.

MESSAGE 3) The “Ring Orb” is hooked on the “C2” & “C3” line but “D3” does not lock on “Imaginary Intercept Point #2”.You can see in the two different pictures “D3” continues to slide and does not lock. I don’t understand why in the exercise before “B2” was locked onto “Imaginary Intercept Point#1” immediately, but in this example “D3” has no idea where to go.

MESSAGE 4 FINAL) I am using the same settings as before. The ring orb is hooked on the “C2” & “C3” line but “D3” is not snapping to “Imaginary Intercept Point #2”. Is there something I am doing differently than before? How would I solve this? Please help

It’s difficult to see what’s happening without looking at the .blend file.

Are the C2-C3 and D2-D3 lines in the same plane?

trying to sent blend file but I keep getting restricted by blenderartistsorg Its reason is because I am a new user…

Yes “C2” & “C3” line and “D2” & “D3” all exist on the same plane

Execise2.blend (1002 KB)
Execise2.blend (1002 KB)

I am not sure which link/ file you need. image

Project was bigger than 5mb so I had to isolate the piece

Found the issue: you need to apply the scale of your objects (ctrl-a, scale, in object mode).

You should always apply the scale of your objects. Especially non-uniform scalings create major issues in all sorts of ways.

Wow thats amazing. It worked first try. thank you. I never even knew scaling was a thing. thank you for helping. I have never “scaled” any of my models I am now going to investigate the purpose of scaling. Thank you. :slight_smile: :heart:

1 Like