Vertex Slide UV correction


I believe in previous releases Vertex Slide had an option to correct the UV… did I dream about it? or it is actually missing for some reason?


Hello Blender users!

I’ve been trying to figure out how to slide edge loops without distorting the Uvs in Blender 2.68a. Without a doubt, I’ve researched this for weeks. I came across a solution regarding uv correction, but nothing happened.

Here is what I’m trying to do:

Create a modular piece (wall)
Bring a texture sheet in containing:door, window and brick texture
and from there, edit the mesh while respecting the uvs.

If anyone can solve this it would be greatly appreciated:)


I am on a mac, blender 2.79b. I can’t find this option either. Has anyone found a solution? F6 doesn’t bring any menu and nothing is on the side panel.

I have no idea what I did differently but now when I created a new loop I got the menu on the side and now it’s working.

Try preferences > Inputs > 3Dview >Mesh > VertexSlide and check the Correct UVs box. Save Preferences.

1 Like