Vertex warp to opposite side cross the axis on mirror modifier (ver. 2.59)

I’m new to these forums, Blender, and English… Please give me the method to resolve my problem.

I’m making a character. I made up a body with the mirror modifier. And then, I made shoes as another object. After that, I combined those two objects.
After setting weight painting, I can’t edit shoes. Because, some vertexes of shoes warp to opposite side cross the axis.

Those unusual vertexes are included both left and right vertex group.
I tried to delete vertexes and remake shoes, but unusual vertex suddenly break out again during editing. I also tried to remove opposite vertex group from unusual vertex. But, the result was same.

Do you know how this problem occur? Please tell me how to resolve.

Attachments


charactor.blend (1.1 MB)

I really don’t know what to tell you srry:(

Welcome to this forum.
The shoe model is broken. For investigation I reduced your blend file to the shoe only.
shoe.blend

If you look into blend file in edit mode you can move one spike with “g”-key. The other spike will move as well. There are no modifiers used in the reduced blend file. This is a model fault.

Nobody can tell you what is wrong but it is a defective model. You have to redesign the shoe. If you use a mirror modifier please design on the left side only.

I like the hair you have designed for the character, but you should start naming your objects before doing animation.

Thanks a lot Ulf B. for your advices. I observed your reduced blend file and found out the cause.
I have applied “mirror modifier” to that object, and “Mesh Options : X-Mirror” to vertexes in the edit mode. I guess that I made two kind of mirroring programs run and confused them. Now, my problem is solved.

I learned that I should avoid the duplication of mirroring programs.

By the way, that hair is not my original. I just followed from a Japanese instruction book. I want to create such a charm character.http://bafull.cgcookie.netdna-cdn.com/images/smilies/sago/eyebrowlift2.gif

P.S.
Canceling “Mesh Option : X-mirror” was the solution.