Vertex Weight Proximity Modifier can't affect particles density

Hi folks,

Is there a way to control a particle system density falloff based on distance from active camera? It’s a concept very similar to LOD.
Peter Guthrie (http://www.peterguthrie.net/) describes a similar method to create grass and save rendertimes in this article: http://www.cgrecord.net/2013/11/soa-academy-day-4-diary-part-3.html - (read paragraph “LIGHTING & MOOD”)
I think he uses 3DS Max, but I’m looking for a solution in blender.

As a workaround I’m currently using a weightpaint group to control it but when using multiple cameras its not a cleaver solution. :spin:

Any tips?

Vertex Weight Proximity Modifier does exactly what I need!

edit:
For some unknown reason this modifier have no effect over the Density slot.
If I put it over the Length slot it works as expected.
Only works over Density slot if I apply the Weight modifier first.

Anyone could confirm if this a default behavior ou it’s a bug?

I made a test sample file. Anyone could test it to confirm if this is a bug?

Blender bug trackers are temporarily read-only due to migration, I have to wait to report it.

Attachments

VertexWeightProximity_issue.blend (161 KB)

Switch on “use modifier stack” in the emission settings, that will have any simulation options take modifiers into account first.

Although I’m a bit confused why length works without it. That’s odd.

Thanks. It works!

But after any change to the modifier, I have to disable and enable again “Use Modifier Stack” button to update particles and see the changes.