Vertices appearing at mid-point only

Hello,

I’m having a bit of a problem. Whenever I go to divide up a mesh, vertices appear at the mid-point of the polygons only – not at the corners where they should be.

Is this a bug, or is there a setting I accidentally switched on that can be turned off?

Thank you.