Vertices "extrude" when I grab them

Hi community

First of all, I’m new to Blender and to this community. I started with blender doing some tutorial on blendercookie and a few time I encountered a problem for which I didn’t found a solution yet.
When I have a mesh and I am modelling around with the vertices, which is usually working fine, at some point, the vertices start to extrude when I try to grab, resize or rotate them. The extruded vertex is then attached to all the vertices on which the original vertex was attached to (which with extrude doesn’t happen).
I wasn’t able to reproduce this problem. The chances are really high that I just accidently pressed a button. But I’d like to which one.

I hope somebody here can help me. (I want to finish my female body :D)

P.S. I’m sorry if I used some weird terms but I’m still learning the “blender-language” :smiley:

It sounds as if you have some duplicated vertices. ‘Remove doubles’ should fix it.

Best wishes,

Hi matthew

Thanks for your answer. I will check that as soon I have the problem again.
How do I remove doubles and how did I duplicate them in the first place?


You might have created extra vertexes by accidentaly hitting E while pushing keys around and having them selected (it happens to me more than once when I’m modeling - I blame my pinky finger).

The solution is here. Remember to stay in Edit mode (TAB key) to be able to see the Mesh Tools buttons :slight_smile: :

There is a shortcut for this but I don’t know it yet sorry. Have fun messing with all the Mesh Tools buttons because most of the problems during modeling can be solved by just clicking on one of them.

Alternatively, you can try to select them one by one and deleting them by hitting DEL key on your keyboard. I also think you need to select all the model (press A key while in Edit Mode) to enable Remove Doubles to work at the same time on all the pesky cloned vertexes that troubles you.

The Remove Doubles function is accessible from the Specials Menu (type ‘w’ when in Edit Mode).

W - remove doubles - F6 - adjust slider around.