Vertices won't move

Hello everyone :slight_smile:

I’ve recently come across a problem that I can’t solve. On one of the objects in the scene I am working on, I enter edit mode to edit the mesh of the object and it appears that every single vertex in the entire mesh is somehow welded in place and I am unable to move it. All the vertices on the other objects can be manipulated just fine. This is only happening with one specific object.

I’m quite sure that this is a useful feature of Blender, activated by a keyboard shortcut that I haven’t learned yet (in fact this happened several times during a university project which brought me damn close to failing the assignment).

So… Can anyone please tell me how to lock/unlock vertices in place, as I seem to have accidentally done???

EDIT: OK this is REALLY wierd. If I switch off the mirror modifier and the subsurf modifier, I can manipulate the vertices just fine. If I switch them back on, the vertices become locked again. I’ve also noticed that my PC slows down a fair amount whenever I switch into edit mode when selecting the affected object - it never used to do that until this problem came along. Can anyone tell me what the hell is happening???

ANOTHER EDIT: I fixed the problem by deleting the mirror and subsurf modifiers, and adding them again. Now the editing is smooth and responsive and I can edit the mesh without problems. So, I no longer have the problem I described… but, as I am always saying in my posts… I don’t know what I did, and if I don’t know what it was that I did then I’m in danger of accidentally doing it again in future… so I would still appreciate it if someone can tell me what went wrong?

Thanks for sharing your problem. I’ll watch for that myself. All I can think is that you locked the translation for the object.

OR Perhaps you had “edit object centers only” or whatever the heck that is called - that’s the only thing that has done this locking effect for me. In some builds, that is the default setting.

I didn’t lock the translation because I could still move the object around in object mode - it was just the vertices that I could not move while I was in edit mode. I’m sure there must be a way of locking individual vertices, and I’m sure I accidentally hit the keyboard short-cut for that while I had the entire mesh selected. I would love to know what that shortcut is :frowning:

Anyway… how do I “lock the translation” as you said? And how do I “edit object centers only”?

The button to turn on “edit object centers only” is on the header.
How ever, it does not work as you expect.
When grabbing, the models move too, but when you select more then one mesh and rotate them, the meshes don’t rotate, but the centers do. Also, if you scale them, the distance between the objects increase, but the meshes don’t get any bigger.