very annoying texturing problem

This problem has happened several times. I should tell you that i unwrapped “project from view” but it seems to happen no matter how i unwrap (look at the image) the eye only shows part of the image Why? I even tried clicking in texture face tab, twosided , but the inside looks the same way What is the problem, how can i get rid of it?

digiman

Attachments


just re sale the eye unwrap faces in Uv editor so taht it covers exactly the eye

should be ok

salutations

Well, judging from the UV unwrapped image, it seems to me like you have some overlapping faces or you have double vertices. Maybe if you post your .blend file, someone can check for sure.

I tried Ricky’s suggestion did not work. Here is the Blend since you have it now Fix the eyes and there is also Black areas on the rear of the tail that i can’t fix ( ithink this might be a bug) when rendering looks normal On the other side of the fish is also black section of dorsal fin. Hopefully you can fix it and please let me know if i did something wrong
Finally, In the game engine you can see the opposite fin right through the fish

digiman

Attachments

FRESHWATER.BLEND (170 KB)

Only had a quick look but your main problem is that some of the normals are pointing inside instead of outside. Select all then use CTRL-N to recalculate them.

As for the fins, the outer polys are only a single sided which means that you will only see the texture on one side. Give the fins some depth and it should resolve itself.

The normals were off I thought of that but when looking on the inside of the eyes couldn’t see the image now that is fixed but the seethrough part is still a problem (look at the image) I added the depth still does not work the reason i think it might be a bug when i start the game engine sometimes i can see the fins the body like the image shows sometimes it looks great

digiman

Attachments


no one knows why i can see-through the textures?

digiman