Very basic modeling question


(GeoffW) #1

Hi

Still getting to grips with Blender, having a problem though with something very simple. I was trying to model a ring shape (letter “0” kinda thing)

I tried three different ways of doing it but all seemed to give me a poor final render, while the model looked ok in edit mode as soon as it was shaded or rendered it looked quite poor as it had artifacts and visible seams.

I was wanting to model it without using subdivs, I created it with 32 vertices around the perimeter, I thought this would look smooth enough when clicking “set smooth” but whichever way I constructed it the render doesnt look totally smooth

Is this something that is to be expected or maybe I just need to use more vertices around the perimeter ?

Thanks for any tips

Geoff


(TRexian) #2

If I were to tackle this, I would start with a tube. Use the loop cut and put about 5 “rows” of vertices around the outside of the tube. Pick the two end sets of verts and scale them “in” - these will be joined to be the inside of the ring.

You can even turn on proportional editing to get the other loops/rows to move with the selected “ends”.

Scale in the axis that runs through the center of the ring to draw the “ends” down to each other.

Then select all and set smooth. The more “rows” (loops) of verts you put in the outside of the tube, the smoother it will be.

For giggles, hit the subsurf button, then a render will give you something like this:
http://i26.photobucket.com/albums/c114/TRexian/Ring.jpg

Is that kinda what you were talking about?

Now, if it were me, I’d probably merge (alt-m) each of the verts that make up the inside of the ring (the ones that had been the “ends” of the tube) - that will give you a nice crisp edge along the inside.


(Lorthien) #3

try these steps:
1 Side view (Keypad 3)
2 Add > Mesh > Circle > 32 vertices
3 SKEY (size) > YKEY (constrain the Y axis) > .3 (resized so the circle is higher than it is wider, you cnaplay with this if you want.)
4 GKEY (grab) > YKEY > Slide the circle a little ways away from the Center Cursor. The length you slide it away becomes the rings radius)
5 Top view (Keypad 7)
6 (You should still be in edit mode all vertices selected) F9 > DEGR: 360 > STEPS > 32
7 Click SPIN
8 WKEY > Remove DOubles
9 CTRL-N > Realign all normals (this is probably why yours didnt look good)
10 Set Smooth
11 Subsurf (try different combos but 2 is good)
12 Render


(TRexian) #4

Cool, Lorthien!

Coupla things, though - shouldn’t that be 360 to spin? Otherwise, the spin doesn’t make it all the way around?

And for some reason, I end up with something more like a cylinder. That’s where playing with the Y scaling is important, right?

Good tips, though.

Edit: scaling in Z helped make it not so tubular. :slight_smile: (Haven’t used that word since the '80s I think…) :slight_smile:


(lirmont) #5

I did something similar to Lorthien:

1 - Make a circle in top view with 9 vertices (32 is way, WAY too many)
2 - Extrude (E) it up 1 unit (z, hold ctrl to snap to gird units) and extrude it down 1 unit
3 - Scale the top and bottom loops to be smaller (S)
4 - Extrude the innermost loops (E), then scale them (S) in some
5 - Extrude the innermost loops (E), then scale them into each other (S, Z, 0)
6 - Press W, then choose “Remove Doubles” with the loops you just scaled into each other.
7 - Press A to select all the vertices, then, in the edit mesh area, press “Set Smooth” and turn on the “Subsurf” button. You should probably have it about 2 (left box) for editing and 3 (right box) for the render value. For it to look smooth in edit mode, you need to press the “Optimal” button
8 - Now, scale the ring however you want to, remembering that pressing X, Y, or Z while scaling will constrain the scale to the respective axis.

Later,
–lir


(Duoas) #6

You can still use your original mesh. The artifacts you are seeing is due to the face normals pointing the wrong way.

All these guys indirectly addressed this in their answer, but the important things are (select your object and enter Edit Mode):
[>] W --> Remove Doubles
[>] Ctrl-N --> Recalculate Normals
[>] Set Smooth
[>] (and if you want) Subsurf

For best results, you’ll also want to make sure your mesh is non-manifold: exactly two faces share any given edge.

Have fun!


(TRexian) #7

Another way to skin the cat (proverbially of course) is to make a UVSphere, hollow out the “core” verts, then proportionally scale the inside ones into the center, until they touch, then remove doubles. :slight_smile:

I think I like the spinning way the best, though. It takes more of the vert positioning out of my hands. :wink:

blender automation = good
my manual modelling = bad

:smiley:


(Duoas) #8

You and me both.

I like to micromanage my vertices. :slight_smile: :o :expressionless:

I’ll use friendly tools to get the basic shape I want… but then I tweak the shape until it confesses.


(TRexian) #9

If beating a blend into submission is wrong, I don’t wanna be right…

Or something like that… :slight_smile:

:Z


(mr_yeahman) #10

yea!! A toaletRING!!! :Z


(GeoffW) #11

Hi

Thanks for all the replies, the modelling tips were interesting and informative to read but that wasnt the thing that was really bugging me.

I went back to a more simple example of just the default scene, replaced the cube with a 16 sided cyclinder. When that is rendered with set smooth on the render artifacts and visible seams are very noticeable.

I guess it is simply more vertices are needed to get a clean render with set smooth on.

Geoff


(lirmont) #12

A higher vertice count is the problem that subsurfacing tries to fix. This is a common way of having your modelling program smooth out your mesh. You just have to activate it:
http://download.blender.org/documentation/htmlI/ch04s02.html (blender doc tutorial)

Later,
–lir


(MADCello) #13

Just make 2 besier circles, one in top view and another in front view.

Scale the second a little (0.5)

Then Bevel the 1st onto the 2nd (F9 > option Bav OB:)