very basic thing, but doesn't works here

Hi everyone,

It is a bit embarrassing to ask this, but I need some suggestion what did I wrong.
I want to load a background image to help the modeling, but for some reason it just doesn’t want to appear.
I have tried various file formats like tga, jpg, bmp, gif but no result.

Is there any trick what I don’t know?

I am using Blender 2.44 but it is the same in 2.43.

Any help is much appreciated :slight_smile:


I have had this problem before when trying to load car blueprints into Blender. When I set them as background image they just didn’t appear… until I used the mouse wheel to zoom in or out and then they randomly popped up. Sorry if this is not a solution to your problem, but this is the only way I can get them to appear for me so I thought I would leave my suggestion just incase.

I’ve noticed, with my wimpy desktop, sometimes images take a while to load, and if I try to do something else before they’ve loaded, they simply don’t show up. So, give Blender 10 to 15 seconds after loading an image before clicking on some other command, it might help.

Another thing that sometimes works is to tab from edit mode to object mode and back again.

Thanks for all the replies.
I have tried everything, but the image didn’t want to appear.
I have downloaded a tutorial file from somewhere which had a reference background image and replaced the image with mine.
After this I have started a new file and the background image option has worked well this time.
Strange, it is may be a small bug in blender, but eventually I managed to make it work with this small trick.
Hope it will work next time too.
Thanks for all the suggestions anyway.:slight_smile: