Very pixelated cycles image

I am trying to render neon signs, using emission material in cycles. When I render the image it is completely pixelated. It looks great in the viewport but terrible when rendered to .png. Adjusting samples value hasn’t made a difference at at, denoising does nothing, resolution on my curves doesnt do anything. I can’t figure it out. Any suggestions?


Also one week new to blender. Still learning, help is appreciated!

PIxelated or noisy ? I don’t find it’s “pixelated”, maybe noisy but it’s not very noisy

Hi.
You circle the portion of the image where you see the problem. Or you try to better describe what you call pixelated.

Edit:
If text is a curve and you are referring to stepped/jagged edges or not smooth edges, check that the visibility for Render in Subdivision modifier is enabled as the visibility for viewport.
Also in Curve settings, you have Bevel Resolution settings where I think that is what you mean when you talk about resolution. But you also have several other settings related to the resolution of curve segments. You can find it at the beginning of curve settings, Resolution (Preview U, Render U). Render U=0 use the configured value for preview.
Also at the end of curve settings, Active Spline (Resolution U)

https://docs.blender.org/manual/en/latest/modeling/curves/properties/index.html

And since this is also confusing for me, here is an @zeauro explanation:
https://developer.blender.org/T54112#485361

Curves are looking fine. Image looks noisy.
I suppose that a volume is used to produce Glow effect.

Volumes are not something efficiently handled by denoisers.
Volume rendering is requesting lots of samples and render time to be satisfying.
Trying to optimize their rendering by tweaking their amount of Steps and Step Rate, is not simple.

That is clearly not the easiest way to achieve that goal for a new user.

You can create a Glow effect at compositing, using Glare node, or in VSE, using a Glow Effect strip.

Well, difficult to know exactly what means by “Pixelated”. This is the only flaw that I had found in the curve:

It is also strange that it is said that in Viewport there is no problem. Noise should be corrected by simply increasing render samples

@emtramp , Just in case, you try to view .png render result in different image viewers.

When I zoom in on the png it’s very pixelated on the curves. I rendered without my glare node and its the same.
[

pixelated.JPG
](https://drive.google.com/file/d/1St2miaYgRZ0dF3sPSrcjz3uma2SEjQSa/view?usp=drivesdk)

Could you make the image public, or share it from another website?

Or even better, you upload the complete blend file and then you share the link here:
https://pasteall.org/blend/

Yeah, unable to get to the image, permission needed.
Sometimes you can get alias stepping from very bright light sources. You can attack this by using a light path node to use a lower power for the emission shader for what the camera (and single ray, if required) sees.