Very slow playback in viewport


I am new to Blender and 3D graphics in general. So please forgive me for the noobish questions.

I am beginning 3D animation, and I am experiencing some very slow playback in the viewport. I’m trying to get 24 FPS but I’m averaging about 8-10 FPS. I downloaded a animation file that I am studying, and the FPS is just super slow. The characters are quite complex and a lot is going on. The viewport sub divisions are set to 0 and I’m still getting incredibly slow frame rates. This is disappointing to me because I bought a workstation desktop computer. The specs are as follows:

Intel Xeon E5-1620 V3 3.5GHZ
16GB of RAM
AMD Firepro W4100 with 2GB of memory
Windows 10 Pro

And I am running Blender 2.78a

I downloaded the latest drivers for my graphics card, and I still get slow playback. I tried change the Compute device in the user preferences> System and that didn’t work.

Like I said before, I am still a noob with this stuff, so I could be missing something.

Thank you,


the viewport needs alot of work. its a limit of blender i believe. subsurfs are one of the slower modifiers, try disabling or reducing the view settings.

Hi, as you already set Subdiv to 0 I am not sure if it help but Compute device setting work only if “Set OpenSubdiv” enabled in modifier.
If nothing help set Viewport shading to Wireframe.

Cheers, mib

Hi. It would be good if you could share a .blend file where you notice the problem. We do not know what elements contain that scene. This could contain physics simulations, particles, etc.

I had similar problem with Blender 2.78 and Nvidia GTX 860M on my laptop. When graphic driver choices Nvidia card for blender.exe, it was realy slow and useless (slow UI, even with empty scene). So I set up graphic driver to use integrated graphic (Intel I7 HD Graphics 4600) and everything is fast and OK. So something is wrong with UI graphics acceleration.

Thank you everyone for the help.

I’ve actually dramatically boosted the frame rate by turning off the hair particles. Everything else looks fine. My frame rate is now 20FPS which is pretty fast for me, compared to 8FPS.

Thank you again,