Video and Audio off sync

In Blender video editor, I notice that the video and its audio track when imported don’t have the same amount of frames. One track will have more than the other which will result in either video will continue without sound or sound will continue without video. Is this a glitch? I don’t like how it appears.

And plus, is there any way to speed up encoding in Blender or is it all hardware dependent such as cpu?

Blender doesn’t recognise the frame rate of your media it just shoves it into what ever frame rate your scene is set to. But audio always runs a set duration. So if your media is 1 minute at 30frames per second and the scene is 60 frames per second, your audio will run 1 minute but the video will only go half as long (as there are half as many frames each second ie. 30 not 60)

So check the frame rate of the media (in a player outside Blender) then alter the project settings to match.
Check out this blog entry too:
http://blendervse.wordpress.com/2012/09/12/vse-improve-playback-performance/

and here is a video that covers this a little bit @1min 30sec ish.

Thanks. Now to my next question: do you know how to speed up the encoder in blender video editor? Is it hardware dependent? The encoder seems to take forever on my Core 2 duo powered computer and that was rendering a still image of 15 minutes as a test.

Ahh that makes sense (: Had similar issues in a 2D animation program a few years back.

Sorry no. It really depends on what you are feeding Blender as strips. Scene media that you are rendering or prerecorded media from a previous render session/camera.

You can however allocate more or less memory to the Sequencer in the User Prefs panel/system.
Here is a blog post.

http://blendervse.wordpress.com/2012/08/01/vse-rendering-tip-memory-handling/