Video as mat not working

I’ve placed a video on a cloth object, but a second into the render, the video stops, and the rest of the animation has that same videoframe on it. Everythings the same fps, the video shows on the object properly… what am I doing wrong?
Thanks for your advice.

Your video may be too short in comparison with the length of your animation. If your video is a loop, you can enable “Cyclic” in the texture panel.

A video texture also has a “frames” setting. Have you set the length of the texture to the length of your animation? Other packages do this by default (detect video length) but Blender does not. The “frames” field only appears if you set your image texture to Movie or Sequence.

Thanks a lot for those tips. Does Blender allow for viewing of sequence window renders mixed with the 3D window content? I thought it did, by pressing both ‘composite’ and ‘sequence’ in the render window, but I can’t get it to do that now. Or do I have to render the video 1st and set it as a background (which appears to work fine). I guess I’m too impatient. :smiley:

EDIT: Drat it, it STILL doesnt update the video as a texture properly. I even tested the video using it as a displacement map and it works fine, but the textre itself just displays the 1st frame and never changes. Any suggestions?

edit again: I UV mapped it to the cube, then must have had a setting wrong. Without UV mapping it it finally shows up fine.

You can add a Scene as a strip in the VSE then put the video underneath that. But the performance goes down the tube because the VSE will do a hi-res render of your scene for everyframe you scrub.

Thanks I’ll keep that in mind, my machine is slow enough…!

I’m having more problems with video though, this time in the Sequence window. When I render a movie with a WAV also placed, i don’t hear any audio in the finished movie! I’ve messed with my Quicktime codecs, as well as the ‘Game framing settings’ in the render window (it was set on ‘no stereo’, i changed it to ‘pageflip’ still with no positive results).

Why isn’t any audio coming through in a movie render from the Sequence window?

Your input is most useful! Thanks again.

You need to render with ffmpeg in order to multiplex an audio file with your video. Alternatively, you can render the video, export the audio track as a .wav and use some other program to mux them.

Nope that doesn’t work either, but thanks for your input. Any other ideas?

Yep, no audio out of Blender using Windows XP. It is a crying shame.


This bug has been here for a year or more, in my reckoning. This really tells me that most users don’t need or use audio with Blender.

The playback and synch of audio in Blender works fine, you just can not render it out (under windows). The way I do it is render out sequences of images and then composite in the audio using After Effects.

Well, I just wrote out a QT movie with audio on XP with 2.48 using ffmpeg and it worked fine. I did use .mp3 as the audio format instead of aac, so there may be some issues with that, but I also think we need to be clear here that the problem is with outputting to QuickTime. Blender on XP can put out some types of video files with muxed audio just fine. I use it that way all the time and can write avi, mp4, mp2, etc.

There may be some bugs in specific instances, but it’s not like you can’t get a muxed file at all.

Not trying to be smart here, but did you press the “multiplex audio” button on the audio format tab?

When I say Quicktime, I mean the quicktime format, not MPEG or AVI. Have you tried outputting to a MOV file using Motion-JPEG-B as the quicktime codec? What about embedding an alpha channel using the ANIMATION codec? I always get a 3FPS frame rate MOV file out of Blender.

I see. I thought you were talking about QT in general, not just the pulldown. Haven’t tried the alpha channel with the Animation codec, but mjpegb worked fine for me (no sound, of course, but the fps was correct.) I don’t use QT much any more, so the ffmpeg version has been ok.

What’s the difference between the two? The ffmpeg version seems to force you to accept the h.264 codec, but is the container itself different? I haven’t run into any compatibility problems but, as I said, we don’t use this much.


Nope. With multiplex on or off in FFMpeg, not in any quicktime format, and to boot the FFMpeg rendered vids show up with an unreadable .dvd format.

What a letdown! No audio from Blender! almost pointless to have a sequence editor.

This is the very 1st letdown Blender’s ever delivered however - it still blows my mind how well it works otherwise.

Thanks, especially for that QT PNG alpha tip, I’d been looking for a way to save them properly.

For some reason, Blender uses the .dvd extension when writing files. Just change the extension to what it should be by renaming the file and see if it plays.