Video Delayed (Final Render vs. VSE)


I have been working on a movie in Blender’s Video Sequence Editor. However, I am experiencing that the video is delayed in the final render in comparison to what I see in the VSE. This means my audio goes out of sync. I need you to help me confirm that you experience the same issue too.

-> Download this zip file.
-> Unzip the files and open the *.blend file.
-> Render the animation in any file format.
-> Use Shift+A to import the rendered animation into the Blender VSE again.
-> Press Shift+Left Arrow & Shift+S. And make sure the rendered video is on top of the other.
-> At this point the rendered video and the original video’s frames should be identical. Go to frame 2343.
-> Observe the Playback screen as you select the rendered video and presss H to hide it.

Is the picture identical to you? Because it is not to me. When I hide the rendered video, the picture changes. The rendered video has not reached the same point of time as the video in the VSE and I am clueless as to why this happens. Help is appreciated!

Please reply to me with your results. If you know how I can fix this problem, then please tell me. But to me it looks like some sort of bug. :frowning:

In advance, thank you so much for helping me out.

Technical details:
Frame 2175 Render = 2238 VSE (Diff 63), Frame 2312 Render = 2444 VSE (Diff 132)

Tested 2.60r41098: The rendered video is identical to the VSE here.
Tested 2.63r45966: The rendered video is identical to the VSE.
Tested 2.64r51026: The rendered video is identical to the VSE.
Tested 2.65r1377: Rendered video is not identical.
Tested 2.65r53916: Rendered video is not identical.

Looks like a regression to me.

EDIT: Submitted a bug report.

Are you playing vse with sync button on av sync?

Yes, I primarily use AV Sync and I have used AV Sync in all builds tested. Changing sync mode does not seem to make a difference here either, but I’ll try again.

Is the audio packed? There can be odd performance issues with audio played from a file, I find that preloaded works better.

@3pointEdit: No the audio is not packed. The audio is not included in the zip file because my tests have shown that the audio doesn’t affect the video, I can reproduce the issue without the audio.

Sorry I can’t download at the moment, do the scenes that you send to the vse have the same frame rate as the vse scene ?

3pointEdit: I am only working in one scene in the VSE, so I am not sending any other scenes to the vse. I am using video.

Anyway, Sergey Sharybin has solved the issue for me. It was because the video somehow was buggy, so the VSE navigation was inaccurate. To fix this, one should make activate Proxy / Timecode and set Timecode to Record Run (for my case at least). See the bug link for further details. Marking this as SOLVED for now.

Sorry since I couldn’t download it, I guess I should have asked what the source media was. Lots of modern camera footage is heavily compressed and relies on lots of temporal guessing. So assigning timecode via proxy is the correct way to address this. I’m not sure why it would have changed though? Perhaps some fiddling with ffmpeg, the built in CODEC suite for Blender?