Video Sequence Editor effects/transitions Playback Stutters Choppy Help? :)

mobo: evga NF68 680i
cpu: core 2 duo 2.4ghz
memory: 4GB 1066 (2x2GB)
video card: evga nvidia 8800GTS 640MB
OS: Windows 7
Blender: 2.57

I am creating some anime music videos AMV for personal fun, clips are generally the length of a single song. I have used Adobe After effects for this before but some of its features are very limited in my opinion, like only being able to work with a .AVI file.

I started exploring alternative softwares and stumbled across blender. I have more or less already figured out how to work the interface. I have cut up and arranged my video (1280x720 720p) into segments. Some places I make a couple video segments overlap, select both segments and apply an affect like gama cross, wipe, or glow. This is where the problem comes in. If I play it back so I can preview it the second it gets to where the effect is, it literally Crawls. maybe 1-2fps.

My first reaction is that maybe blender is running in software mode and not making full use of my Nvidia card or something, or maybe there is a setting I can set in blender so that it buffers or something before trying to play it back.

Does anyone know what all I can try or test to get the playback smooth in the preview playback. If I render the video and save the file it actually looks fine. but I need to be able to play it back in the preview so that I can make adjustments and tweaks. I have to line up the frames perfectly so that every time there is a drum beat my video transitions to the next video segment or plays the effect.

Is there a test or anything I can do to check that blender is using hardware mode (my drivers) and not running the preview using software rendering or something.

Also are there any settings to make playback in the preview smoothers, like low quality mode or more buffering or anything??

Thank you so much for any help :slight_smile:

I believe the Sequencer currently isn’t gpu accelerated. You can force it to drop frames so it runs in real time but this may not be appropriate in your case (In the timeline Playback menu select AV-Sync and Frame Dropping options)

I have more information for you. On the same computer if I boot into Ubuntu 10.10 I can load the same file and playback is almost perfect through the transitions and effects, it only drops a couple of frames, and you almost don’t even notice it.

The exact same *.blend in Windows 7 and playback is super smooth until it hits the effect/transition and then it just hangs. drops down to almost no frames 1-2fps until it gets through the effect/transition.

I would really like to fix this, and if you need any further information for reproduce-ability then please let me know and I will do everything I possibly can to help.

Looked through more settings, but I’m not getting anywhere. Preview Playback through transitions/effects just hangs in windows but is almost perfect in Ubuntu. Anyone got any ideas?

Can you run a system monitor during playback? See if you are maxing out processor or memory?