Video texture overlaid in camera view

I saw this done in Colin Levy’s Snurgle shot video tutorial, but I couldn’t figure out how to do it myself. He had the video he was using as a background displayed in the camera view, and it animated with the scene - i.e., playing through its frames as the Blender animation did. I’ve searched the forums and only found suggestions like making a plane and putting the movie onto it, but it didn’t look like that was happening in the video.
When I go to the background image dialog, there is a button beside the ‘texture’ field, but there’s no drop down menu. How do I load a movie into the texture list?

Create a Plane, create a material for it, then create a texture (image), load the image(movie), click on the Movie button in the Material/Image panel, then (optionally rename the Texture in the texture panel), then choose that texture in the background image/texture dropdown. I haven’t seen the Snurgle tutorial (have you got a link to it), so I’m not sure what other differences you’re seeing, or if that in fact was the same technique used.


Here’s the tutorial - it’s the first one on the page.
Check out the rest of that site as well, there’s some pretty cool stuff done with Blender.

Anyway, that method didn’t work. I’ve got the texture loaded, and here are the settings:
I selected texture ‘Movie’ from the drop down menu in the background image options, but nothing happened.

I notice that you’re trying to load one of those icarus movies. I had trouble playing those movies on my system (WinXP). Needs a weird codec, was mentioned in an Icarus/compositing thread here awhile ago. I’ll go find the thread. But if the video won’t play by just double clicking on it from explorer/my computer …etc, it’s not going to play in Blender either. Another way to check a video is to try loading it into the Blender sequence editor.


Hmm… you’re right. I stuck in another movie, and it worked fine. Thanks for the help!