video texture problem

I cannot get my video texture to work.

I enclose two example files. In file video_texture2.blend (which I copied and modified from a Blendercookie tutorial example) the video plays OK. In file video_texture4.blend (which I constructed myself using their method) the video does not play :frowning: .

Can somebody please tell me what is wrong with video_texture4.blend ?

Thanks in advance!

sculptorjim

Sorry - the attachment didnt work! Still trying.

sculptorjim

sculptorjim , there are no enclosed files in your post.

xaedro, I seem to be unable to upload the 4.7MB zip file for attachment (it just seems to go on “uploading” for ever. What am I doing wrong?

I haven’t seen the tutorial you’d mentioned, and obviously i haven’t seen your .blend, so i can only guess. Have you edit the script to point to your video location correctly? What video format you are using? I mean, is the format really supported in bge?

Here is another tutorial you might want to try:
http://www.tutorialsforblender3d.com/Game_Engine/VideoTexture/VideoTexture_Movie_1.html
It’s for blender 2.49 but there is a script for blender 2.6 as well.

And here is a video tutorial for blender 2.6 based on the above tutorial.

Edit: Basic script and documentation that might can give you more clues.
http://www.blender.org/documentation/blender_python_api_2_63_17/bge.texture.html

Many thanks to whoever wrote that blender API documentation :).

xaedro and dConclusionman: Many thanks for your help, and for pointer to python documentation (particularly useful). Sorry I couldnt attach problem file: as a point of order, how DO you attach files to these posts? Any help welcome!

Try to blend in some hosting site like Mediafire and provide the link to download.:wink:

Thanks firefox. Will try mediafire.

Here is a link to the combined download:

As asked previously, can anyone tell me why video_texture4.blend does not play the video?

I tested the last official build of Blender (http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.64) and the sensor videotexture4.blend Always blend the pusle Mode was turned off, put in True and it worked.:yes:

Do not forget to have the video and audio codecs updated. Use the latest version of the Klite Codec Pack.:wink:

firefox: Many thanks - that was the problem. And for your help with attachments.