Video turns to black after some seconds

I have encountered a problem when exporting videos with Blender 2.45. I use generally the Avi Jpeg format (Motion JPEG). Since Blender 2.45, when I import a video produced by Blender in an other video editor (Magix Video Deluxe 2007 Plus), the image becomes fully black after some seconds.
If I convert the file into VirtualDub (in uncompressed video,or even using the same format MJPG), VirtualDub repairs the file, and it is fully readable in my video editor (Magix).
It looks like there is something wrong in the export code, or in the MJPG codec.
Exporting in sequence of image is OK, but it neads a lot of memory for long sequences !
Weird thing !
I’m running Blender on a P4-3GHz (one core) 2GB Ram, under Windows XP SP2 Home Edition.

No ideas ?

It probably has something to do with the tags on the file or something along those lines. I just used MotionJPEG last week for then seconds of abstract background (Blender made) and I haven’t had any problems with it in After Effects.
If I had Magix Video Deluxe 2007 Plus I would try to confirm your problem but unfortunately I don’t have it.
You might try comparing the broken and fixed versions side by side to see if there is any difference in the file sizes.

Good Luck.

sounds like a bug crept into one of the oldest codecs. I think I had some issues with Microsoft Media Player playing avi jpegs, but another player (QT?) played it just fine - could have been than WMP was barfing on the bug, but QT worked around it. If you can make it reproducible using a simple blend file, I would submit it as a bug. You can post your blend file here and one of us will replicate the issue…

Well, I can’t put one of my last blend files as an example because they are confidential works for a customer, but it occured on each recent render, and seems to appear on every animation which is long enough (around 1 minute of duration). So it should be repeatable with the animation of a simple cube.

rendering a 10-second cube now 50% of PC settings to avi jpeg. Rendering is much slower, i notice, even with OSA and Shadow etc off. - 1 second per frame when before it would have whizzed by. Oh well, the price of progress.

I dont have Magix Video, but do use their Audio products. I would not rule out a bug in Magix…

Plays fine in WMP and Divx6. Sorry, sounds like a Magix bug.

Thanks for testing.
The weird thing is that the file is repaired by VirtualDub, so the trouble seems to come from Blender. My machine with Magix installed is not available these days, so I can’t do more tests on it currently.
If you have Magix Music Maker, it allows to play some video formats. Maybe you could try reading your rendered file with it ?