View Layer - Use for Rendering keyframes not working

Hi there,

I’ve got a problem with the animation of the “Use for Rendering” property for the View Layers.
I’m using Blender 2.92 and rendering in Eevee.

I’ve got 12 view layers, to render a specific and complex compositing for a animated painting effect.
I want not the 12 render layers to render themselves at each frame, but at specific moments of the animation.

For example at the beginning, I only want 2 layers to render, then at 100 frames, the next 2 render layers, etc …

So I tried to keyframe the Use for Rendering property, but then, it is not working at all.
It’s really buggy, so if I go to another view layer, none of my keyframes are working anymore.
It’s supposed to, because everything seems fine in the Dope Sheet, but then, the properties are going crazy, like rewrite on the checkbox so it’s back to False, or True, or whatever.

Then, I tried to animate them with driver. I was thinking, it would better work.
But nope. When I use driver, I create a custom property in the Scene, so all the view layers can have access to it. Then I animate it and use the value to animate the Use for Rendering, between 0 and 1.
It’s working, yes !! But when I switch to another view layer and come back, it’s not working anymore …

Please help !!!

How can I animate the rendering property of a layer so it’s not rendering each frame but only the frames I choose ?


Did you figure it out in the meantime? i have the same problem right now, and the result in terms of which layers are being rendered or not is so random that I’m not even sure that this “use for rendering” property is what I think it is at all.


It was a long time ago, and I did not used this option since then.

If I have some time I’ll try some tests !

Good luck,