View layers rendering multiple times unneccesery

I’ve came across a problem.
I’ve set up a file with two scenes - one to be rendered in Cycles, second in Eevee. Each scene has 4 view layers. I’ve set up nodes in compositor (in cycles scene) with multiple render layers that are just saved later to drive by File Output node.

Now when rendering, Cycles renders 4 scenes, but Eevee renders 16 scenes (each view layer 4 times). So Eevee render takes 4 times longer.

I also made a new file with similar setup but only with cubes/spheres and it’s same problem. I’m attaching it.

Is it a bug, a feature, or I made something wrong?

multiple_render.blend (1.1 MB)

Pal, check your work. The file has indeed two scenes to be rendered, but 1) “eevee” has NO render settings at all and 2) the scenes are set up totally different.

I made a full copy of your “cycles” scene as “”, set the view layers exactly as in “cycles” and changed the render engine to eevee. I got 4 render layers. And it rendered slightly faster than in cycles.

Thanks for reply.

  1. What do you mean no render settings? No nodes in composing? It’s because I don’t want to render through this scene. But even with same render nodes setup or with standard settings (single render layer and single composite node) it is still rendering scene multiple times. I’ve also noticed right now that blender renders all view layers from eevee scene for each render layer in compositor. Also it looks like it applies to other scenes then one you render from. If I try to render same setup from eevee scene, it will render cycles scene multiple times.

  2. Isn’t it the whole point of having scenes? I want them to be totally different to render different things with different setting and then use render layers to compose all these rendered images into one picture.

In my main project I want to render few objects in cycle, and smoke in eevee (since cycles with smoke takes years and effect of eevee is good enough for me). They need to be in certain order that is why I have several view layers (and smoke does not have z data). So in the end I want to put them together like cycles over eevee over cycles and so on.

Ok, now everything is clear. It was a bug and I updated Blender 2.8 version to new one and it renders each render layer only once.