Viewport aliasing/glitching issues

Anyone know why this is happening? I’ve never seen this happen before. I’m on 3.3. Tried setting viewport AA to max, but it has no effect. It seems to be at its worst when object interpenetrate. Cheers.

It looks like Z-fighting, not aliasing.
Try to reduce the difference between the camera / viewport Clip Start and Clip End.

3 Likes

Is this rendered view, eevee? Have you tried increasing the shadow map resolution under render properties-> shadows ?

Perfect. This did it. Thanks. :+1:

This is workbench matcap. Thanks for the reply. :+1:

2 Likes

Another issue is the edge thickness in edit mode. The edges are so thin that they are glitching. They are ok in (top image)object mode?


Afaik the edge thickness itself isnt editable, try changing the settings in preferences->viewport->quality.

One more thing. I think you need restart blender to get an effect.

1 Like

That didn’t help, unfortunately. I don’t remember the quality of edges ever being that bad. I remember edges being a lot thicker in edit mode. They’re so thin here that the pixels are completely stretched/broken.

Hmm. Yeah it looks better here. Do you use a 4k display? Just to be sure , you did use AA and Smooth wires for Edit mode in the prefs?

Yes, 32 AA and smooth wire. I’m on 4K monitor, yes.

For me, there’s no difference between AA off and 32 samples.

And the line width under prefs->interface->display is also at thick? Be aware that does also change settings like the panel border widths etc.

1 Like

Ah yes, that helped a lot. Still aliased, but a lot better than it was. Thanks again.

1 Like

It’s weird though that the object mode wireframe is perfectly smooth, but edit mode is jagged?

Perhaps AA now has an influence. But as I said. restart blender after having changed it.

Yes, I’ve restarted with 32 and it’s not too bad. Not perfect, but better than it was. Must be the 4K monitor because I never had it as bad as it is now and always had line thickness set to default.

1 Like

I am not sure why. Maybe the overlay for edge selection is implemented differently to be faster. But thats just me guessing.

1 Like

Yeah I’ve read something about related problems with retina displays quite some time ago. But I think its not easy to find again. Good to hear its better now. Are the lines at least continous now?

1 Like

No, they’re still poor quality.
image

1 Like

Yes, not sure if its ok to put a like on that post… :joy:
Wait a second I will try if I find that retina discussion.

:laughing:

:+1:

No, I couldnt find it. A last thing that came to my mind was to try if changing resolution scale under prefs->interface->display does help, but I guess not that much.

1 Like