Viewport Artifacts

Hi there,

I’ve this problem in having meshes displayed properly in blender. At first I though that it had something to do with Blender 2.5x series but seeing clean view port renders in others made me suspect that something is not right with my machine. Do you have any idea why these artifacts occur? I tried ignoring them but they do tend to be ugly! And annoying! Is it my hardware that’s the culprit? Or something else I’m ignoring? My graphic card is a GTS 450.

I have checked the normals. They all point the way they should.

Here are some screen shots of the problems I’m facing.

Any reply would be much appreciated,

Thanking you,


I think the artifacts with the ship might be another mesh on the inside that is just a wee bit too big, that’s what it looks like to me anyway. Have you tried W >> Remove Doubles? (in editmode with all faces selected)

the second one(err…the one titled 3.jpg?) looks like classic z fighting
so yeah, like JamesNZ said…remove doubles.

Thanks for the reply!

I did not know it had a name! But no, there are no doubles. I’ve tried Removing the doubles too (Got the reply that there were none to be deleted.)

And the last image, the one with a sphere in it, that’s a ‘fresh’ one. Just added it added from Add -> Mesh -> UV Sphere. And most of the time this happens only when the view is orthographic (Not the image with the rectangle though).

Maybe a clipping issue? Although this does look like doubled geometry. Are your drivers up to date for the card?

Just added it added from Add -> Mesh -> UV Sphere.

thats a huge clue…if the default mesh is behaving that way, it is almost for sure a graphics issue.
like ajm said, try updating your drivers, and maybe play around with the different draw settings (Ctrl-Alt-U -> System tab -> Windows Draw Method)
its strange, display problems in blender are very common for integrated intel graphics, but nvidia is supposed to be “the best”…
let us know if it works!

Nope. I downloaded the latest driver for my card from Nvidia. Had the defaults settings but the results are the same. I messed around with the different Draw Methods as well. But to no avail. I wonder what IS the problem! Could it be a defective hardware? Or something with windows 7 itself? Maybe some important setting with I ignorantly turned off? I’ll keep looking.