Viewport dead

Brand new shiny Mac Pro, fresh Blender 2.80 installed with today’s version. Blender launches but I can’t do anything that involves clicking and/or draggin in the viewport. I can click on the tabs (layout, modeling, sculpting etc), the tools on the left side and I can go in the menus too. I can use the gizmos to move the camera. I can’t move the timeline either. If I check in the prefs, in Systems, I don’t see any graphic card in Cycle Render Device. Any mouse clicks in the viewport don’t do anything. In the file browser, clicking on things don’t do anything either.

Help me Obi-Wan Kenobe. You’re my only hope.

Try downloading a new MacOS 2.80 now that the nightly builds have run. There have been a higher than usual number of changes each day lately so I would try another build before worrying too much.

Have you used 2.80 before/recently? There are a lot of differences between it and 2.79. Moving the timeline just changed a couple days ago and (in left click select mode at least) requires dragging the “play head” at the top where the row of frame numbers is.

I only use 2.80. I can’t stand 2.79 (Long time Maya user…). I customized 2.80 so much that I’m at 90% of what I can do with Maya as far as modelling goes. And if I had box cutter and hardOps, I’m even better in some cases. I’ve been using 2.80 for about a month now. I will try the new version tomorrow morning.

Cycles OpenCL rendering on macOS is no longer supported… and that have to do with Apple pulling OpenCL support. Not sure why would anyone buy Mac Pro for 3d to begin with, unless you really need to be able to boot in macOS for something.

As for other problems, you should report them as bugs and post full specs of your Mac Pro.

True, but that should not have any effect on viewport behavior or Eevee etc.

The System Preferences for Cycles Compute Device have no effect on Blender other than when rendering with Cycles. It does not affect which device is used for OpenGL etc.

If the MacBook has both Intel integrated graphics and AMD discreet graphics, you may want to see which one is in use.

Not my Mac. It’s the office’s. They hate Windows and we use the Macs only for zBrush. Otherwise we’re on Linux. But I can’t run 2.80 on Linux because we don’t use the same version of Python and IT doesn’t want to change it because it could break our pipeline. And I would prefer to use Blender on the Mac because of the CMD key that allows you to have a whole new extra set of hotkeys. I used to be the biggest Apple fan… used to…

Blender doesn’t use it’s bundled Python version on Linux by default? You should be able to point it to whatever Python runtime you like and not have any conflicts with anything else on the system.

Rename your pref folder and launch a factory default one to see if your issue arises from settings.

Where is the pref folder on Linux? Anyways, I don’t think one was ever created since I can’t launch Blender. This is what I get:

./blender: error while loading shared libraries: libmvec.so.1: cannot open shared object file: No such file or directory

Well, you need to tell about your system specs, operating system, how you installed it, opengl driver version, what graphics card you etc. I do not even know how you would be missing libvec. You might have a borked system installation

Looks like you’re running CentOS or similar, which still has really old system libraries (damn you RedHat and your Enterprise compatibility!) so I would suggest trying the Graphicall CentOS build here (unless you want to build it yourself):

Yes, we are on CentOS. I downloaded the enterprise version. When I try to launch it I get this message: There is no application installed for “executable” files. Do you want to search for an application to open this file?

EDIT: I just needed to change the permissions to make it executable. It works! Thanks guys!

1 Like