Viewport different results than render (shrinkwrap)

HI I am using a shrink wrap modifier along with a dynamic paint modifier. The idea is to make a roll lay in a specific shape (shrinkwrap shape). As you can see it works in the viewport:

But render is not showing the same (green shrinkwrap surface , yellow roll is not following here)

Do anyone experienced this before?

I am realizing now, other part of my animation has the same procedure with a different shape as a shrinkwrap and doesnot work either in the render window. It shows perfectly in viewport mode.

Wondering what is happening, I checked my visibility options in each modifier and everything have been turned on.


Are you using subsurf? Make sure view and render match, in your case best to set both to 1

1 Like

Thank you for the tip, it was actually that. I need both at 3 (with one I do not have much polygons to bend the surface). But it worked when I match bot values Render and Viewport. It is quite a shame it does not work with different values…that is the hole idea of having to parameters in the subdivision modifier I guess.

1 Like

Hi , I am sorry to bother you agian, it is happening again now, both viewport and subd are the same value. Do you think it could be a bug?

can you show a screenshot of your modifier stack?

Hi ! thank you.
I managed to make it work at least …fairly. Now the shrink wrap renders as I was expecting (with the shape of the shrink wrap target. What I did: I pressed the invert vertex group button:

Might be that the vertex assigned are wrong? i have my vertex group created, but empty in a way no vertex are assigned. It worked well with other mesh. I copied the technique from another user in the forum.

I am not sure why by pressing the invert button worked (since nothing is actually assigned).
Still the viewport shows a different thing than the render. Not that important since it works in the render, but in the viewport I need to invert it again to see it as the render…

Thanks a lot for your time and dedication!

your screenshot cut off I cant see all the modifiers, post 2 or more image if you have to and don’t collapse any of them.

Also are you maybe using the ‘simplify’ option? I so, disable it.

I left the office. I will send it tomorrow, thank you

Are you baking your dynamic paint? Because you have to for it to work. Might be worth checking out the vertex weight proximity modifier as well for this project.

I am not, I will try now. I am new with this. I can see I have a purple line under my timeline each time I play the animation. It is a bit frustrating, sometimes works sometimes not…I left to animate overnight, came to the studio…and was not working…

I will try to bake it now and see how develops
Thank you