Viewport doesen't match final render?


left is viewport, right is rendered.

why does the red liquid part look so dark and rough? I am using a HDRI for lighting which I have turned transparent in Render Properties > FIlm > Transparent. fiddling with these options doesn’t seem to change the problem.

Is the rendered image actually transparent?

Is the viewport image in eevee render mode, cycles render mode, or material preview mode (which is also eevee)?

Is your outliner set to show the eyeball and camera AND tv screen icons? Do you have eyeball enabled for all lights but one of the other icons is not enabled on some lights?

I have no actual scene lights, figured the HDRI did the trick? it looks like it is getting lit the same way as the viewport, but light isn’t really passing through it the same way.

Here it is without transparency, plus a screenshot of the outliner.

Ok make a simplified test case in a new empty file.
Make 3 spheres next to each other.
Put your materials one on each sphere.
Use the same HDRI.
Render that and see if there is still a difference betwen viewport cycles render and final render.

Do you have any modifiers on any of the objects? Is the camera icon enabled on all modifiers?

Ah, thank you. the problem was that i wasn’t seeing my solidify modifier on the glass in the viewport, but it showed up in the render. thank you for your help!