Viewport gets slow when importing minecraft world (.obj)

Hi!
In blender my vieport gets 3 fps, if i import a minecraft world into it.
Example of what i have in viewport:



Any help how could i get more fps?
Without the minecraft world imported i have 60 fps.
Tnx

How many total polygons ?
The more blender has to display the slower the fps
Ensure you are using the latest version of blender. You can hide selected objects /faces with H

That reminded me that I needed to update the Mineblend addon for exactly this reason (performance). Not sure what you are currently using to import your Minecraft worlds, but you might want to take a look at it: http://randomsamples.info/project/mineblend/ In general, Minecraft viewports and rendering are probably going to be relatively slower than traditional models due to the amount of geometry needed to map voxels to geometry. The latest update to Mineblend significantly reduces this by eliminating voxels that aren’t visible (i.e. dirt hidden behind dirt etc.) while still keeping the what is needed to render underground scenes. It also has options to hide some of the common block types in the viewport when importing which further improves viewport framerates.