Viewport lag with GTX Titan

Why is my viewport lagging in Blender 2.77a with Titan? And what can I do to avoid it?

I wanted to enable VBO, but I can no longer find that option.

I am running Win10.

The same problem is with my new 1070 card with the kernel sm_61, so I assume Blender is the cause of the problem.