Viewport navigation stops working

I keep running into this very annoying view port navigation problem in Blender. It usually seems to happen when I zoom in too far and then I can’t pan or zoom back out. I can still rotate the view fine. The only think that seems to fix it is reseting the view doing a frame selected or frame all but then I have to start from square one again. Do I have a setting set wrong that might cause this? What’s happening and is there anything I can do to avoid it?

Here’s a dropbox link to a .blend file I have that was saved while exhibiting this problem. I removed everything else from the file so it’s nice and small.

Dont know how this happens, but for me SHIFT+c for frame all sloves.

Yes using frame selected or frame all temporarily fixes it by reseting the view but then you are back to square one and have to start all over again and navigate to where you wanted to be and end up with the same issue.

I have used Lightwave and Modo professionally for years and have never seen a navigation issue like this before. I’m stress testing Blender and in the process of learning it since I’m considering using it as my main 3d production tool eventually.

I did some more tests comparing navigation in other software and it appears this is just how Blender works which is a bit annoying. This will require frame selected to be using very frequently when working.

I’m not sure if it will help, but there are other options for the zoom method in Preferences → Navigation → Zoom → Zoom Method. You could try some of those.

I’m assuming you’re using the MMB to scroll? You can activate a slightly different type of scrolling that isn’t as object-contextual with CTRL-SHIFT-MMB

I have noticed “zooming problems” when the view is set to Perspective… rather than Orthographic.

Orthographic always works as expected.

But, in Perspective (just as you describe) the “zooming” seems to stop working.

Hope this helps.

Yes I also noticed that when I was trying different things it seems to work fine with orthographic. I don’t really like working in ortho view though. I think this is just one of those Blender weird annoying quirks that I might just have to try and accept and work around it if I can.

I tried messing around with that but it doesn’t seem to help.

I dont zoom in/out a lot, and nearly never have this problem. I mostly use zoom to selected with , on numpad and zoom out.

Maybe check “Depth” option in preferences will slove this.