Viewport running slow

I noted that when pressing spacebar and play animation in viewport this runs about 66% slower than normal. I compared it with my smartphone chronometer, I’m using 24 fps. Then I cannot see the real animation until I render it. Whats wrong ?

  1. The first and most import area to address is make sure no modifiers are active, subserf, cloth, etc. I’m guessing that things like poly count are going to tax a systems resource too, so… Also limit what you have viewable in your scene. If you hide everything and only work with the mesh you are animating at any one time you should be ok. (Computer specs dependent) Some here have been able to run animations at 60fps and others top out at 24fps.

  2. I’m pretty sure your machine specs are going to play a major part in this, so viewport performance for Animation will vary from user to user.
    Saying that, I’m getting a huge variation between the two OS systems I use for Blender (same file, and same computer, a Mac Bootcamped). Mac OS will handle the animation at 60fps with zero issues, including leaving the rig unhidden. Windows (Bootcamp) is struggling to get me 30fps with the rig hidden.

At this point I’m assuming the AMD (Bootcamp) drivers aren’t optimized to work with windows (I have the latest official AMD drivers for Bootcamp direct from AMD’s support page). Maybe the Blender port for Mac is slightly more streamlined, (purely speculation on both counts by me).
I truly don’t know why there is such a large discrepancy, but I animate and do normal blender task on my Mac and then jump over to the Windows version for any rendering with cycles, because I need OpenCL for that to work with my GPU. And of course Cycles no longer renders with a GPU on my Mac.

I only mention my Mac performance because you haven’t made clear what system you are working on.

Take this with a grain of salt because I’m not an expert on how Blender uses the hardware while running animations in the viewport. These are purely my findings, but these measures used to enhance viewport performance while working on animations, have been echoed across the forum it seems.

Hope this helps,

at this time I tested animating in wireframe and also on solid mode and speed is OK. My Mac mini is so old and I think is the only option just now

Glad you got it working at a usable frame rate.
I too have to work with almost everything hidden. I’m a little jelly of big studios that have workstations capable of running viewport rendered animations in real-time. :slight_smile:

how can I hide modifiers? what another can I hide?

For each modifier there will be a small TV and Camera icon. TV icon is for viewport and the Camera icon is for rendering.

Anything in your scene that you’re not trying to animate at the moment.