Viewport Shading Issues with GIT

I typically run a self-compiled GIT and the latest release side-by-side when experimenting and working. I’ve noticed that lately, when I set my Viewport Shading from Solid to Textured or Materials, viewport performance drops precipitously. There’s a HUGE delay when I go to rotate the view of the model. It works fine when I set it back to Solid. This started with the libs that had been working fine with SVN and GIT up until recently, and still happens with a freshly compiled set of libs. Blender 2.69 works perfectly. Issue spans two of my computers as well - one 32bit and the other 64bit. Have they made a fundamental change? I looked in Preferences to see if I need to tweak the settings but nothing jumps out. GIT renders perfectly fine in Cycles on my GTX cards too, so I don’t think it’s a driver issue either.

Latest GIT still has the same issue on both 64bit and 32bit Ubuntu-Studio systems. Fresh run of (after deleting ~/src and /opt/lib dirs). Not sure if this is just an in-development quirk, or if a setting requirement has changed from 2.69, or if my build environment has developed an inadequacy. Up until a few weeks ago, builds from GIT worked perfectly. Unfortunately, for a project I’m working on, only GIT can render it without crashing. 2.69 routinely crashes near the end of the renders for some reason. But it’s node-heavy rendering too. So for the most part I’m stuck with Solid shading on the viewport. Which isn’t a show-stopper, but it would be nice to put Textured shading back on. Helps with visualizing the finished product as I work.

Maybe you could tell me why when I go into full screen mode (shift-space) in the node editor, it becomes painfully laggy. 2.68, 2.69.

Perhaps a new thread with that question would prove fruitful for you. I’m just trying to track down where the discrepancy lays with my issue so I can determine if I need to make an adjustment to settings I’ve yet to find, or revise my build environment, or submit a bug report. It would seem that I’m the only one to have encountered this or there are few if any using GIT versions of Blender on this forum. If it’s the former, then I need to investigate my build environment again. I’ve not seen any bug reports remotely similar to my issue so it’s possible either mine is isolated and due to errors in my own environment, or other GIT users are waiting for the “bug” to be ironed out, which on occasion does happen.

Here is a screenshot of my basic skin texture node tree. Pretty much all the skin textures are the same, excepting a simple transparent/glossy node for the cornea and tear objects. I’ve tried turning off all the particle modifiers too, but no change. Still a very very heavy lag-time when I go to Texture (or Materials) view.