Viewport shortcut 1, 3, 7, 9 wont switch to orto

I just got my new pc setup, and when i switch to the side views itll stay in either orto or perspective as it is set with 5.

before this i was able to just switch to 1,3,7,9 and it would automatically switch to orto until i switch back when i move the view.

how do i get it back to this?

If your trying to switch with the numbers on the top row of the keyboard:
You may need to enable ‘Emulate Numpad’ In User Prefs > Input.

If that option is unchecked, it will just toggle the associated layers.

Else the numbers on the numpad should work as you expect.
Or try loading the Factory Defaults…?

User preferences -> interface: auto perspective.

thanks for the help guys!