Viewport - Texture - Checkered Pattern

I’m relatively new to Blender, so I’m sure this is an easy fix. I’ve been searching for a solution, but I can’t find anything.

I’m using Blender 2.63 on Mac OSX 10.5.8 (Leopard). Just started messing around with the Cycles engine. When I am in the Texture viewport shading mode, my meshes have a checkboard pattern. What’s going on here? Why isn’t it solid?

Attachments


I made a new mesh to figure out where this checkered pattern appears, but I don’t know why it happens.

  1. add a circle mesh
  2. subdivide to add more vertices (this causes the checkerboard)
  3. extrude

Is there a better way to add vertices to a circle to avoid this?

Ah… I could add more vertices in the circle settings, instead of subdividing. Still, why does a subdivide cause the checkerboard pattern? That still confuses me.

I just noticed that there’s still one face that is darker than the others, even when I add vertices with the circle option instead of subdivide. I don’t understand.

Attachments


Try recalculating the normals, Blender will fail at producing consistent normals at times when extruding a wireframe shape for some reason (it either does not do any auto-calculation of normals or it’s calculation for the ‘add circle’ operator is messed up)

Recalculating the normals seems to do the trick. I knew it would be something simple. Thanks, Ace!