Viewport Transparency: Designed Feature? Bug?


#1

Hi. I’m sorry if this has been asked before, but I’ve searched though blenderartist and was unable to find an answer to this.

In short, I’ve notice the transparency doesn’t work the same across the different viewport shading mode, as in how they act. This disregards the lighting and color difference in the different viewports. Here’s a comparison between ‘Texture Mode’ and ‘Rendered Mode’.

For some reason, ‘Texture Mode’ object transparency only see-through the none transparent objects (the red plane and black column), while the ‘Rendered mode’ see-through all the transparent objects.

Similar event happens when switched to other viewport mode, where ‘Material Mode’ also only see-through the none transparent objects and ‘Solid Mode’ see-through all the transparent objects.

So blender artists users, is this a designed feature, a bug or did I missed something that should have made them at least acted the same?

Your help would be greatly appreciated.

Steps to Reproduce Situation

-use Blender 2.76b 64bit in Windows 7
-set to Engine mode to default ‘Blender Render’
-set shading mode to ‘GLSL’ and check ‘Backface Culling’
-create a few separate planes with transparency checked at an alpha of 0.3
-uncheck shadow ‘Receive’ and ‘Cast’ for all of those transparent planes
-check ‘Transparency’ under ‘Object Panel/Display’

Related Tags: Viewport, Transparency, Transparent, Texture Mode, Rendered Mode, Solid Mode, Material Mode, Blender Render Engine


(yogyog) #2

Blender has struggled with real-time transparency for a while now. Eevee seems to be fixing it.


#3

Thanks for the reply.

I’ll just presume that it’s a thing (both a feature and a bug) that happens in blender.