virtual "studio"

I’m pathetically modelling this thing and wanted some nice lighting setup and I realised I can’t even do that.

Is there a way to make yafray render “shadow only” material properly?
If not, how do I make a nice studio-like setup for objects to cast shadows on? I tried modelling this round floor-to-wall thing, but it’s having some weird shading:

http://jimmac.musichall.cz/screenshots/screenshot-628864000.jpg
http://jimmac.musichall.cz/stuff/blender/totem.png

I don’t use yafray much so I don’t know about the only shadow thing.

If you want the traditional white background style where it looks like infinite white space like in the Matrix or on some TV adverts, you can do this:

Make a plane for the floor and in the material settings, go into material transp and turn on only shadows. In the world settings, at the opposite end to the lamp buttons, make the environment whatever colour (white is good). Now the plane renders the shadows and the rest is pure white with no shading at the back.

If you want some shading, like in your test image, experiment with the world settings by turning on blend for example and maybe changing the zenith and horizon colours.

The only problem you might encounter here is that extra lamps don’t seem to illuminate shadows unless they cast shadows themselves. That’s because the plane only receives shadows and nothing else. This means that if you only want your object to cast one shadow, it will be pitch black not light grey as in your picture. A way round this is to change the alpha value of the plane material. This lightens your shadows. Some tests gave me this result:

http://members.lycos.co.uk/ajr650/tmp/studiotest.png

osxrules was pretty close. Again, as he said the only problem is that the lighting isn’t right. To fix this, just use a sun light source and then use a nother light source that only casts shadows. In the case of this image, I used a buffer shadowed spotlight.

http://www.zerohaven.com/gmoyes/forum-images/whitebackdrop-test.jpg

You can get the blender file here.

Sun lightsource of about energy 2 seemed to work. Raise the energy on the shadow-only light source to increase the darkness of the shadow. The only problem as you can see is that when you turn anti-aliasing on, it creates an outline. If you don’t use anti-aliasing, there’s no problem. However, all you have to do to fix that is create an object, or put the scene in a white box with the emit set to 1. That will fix that problem (that’s why I put that plane in the background so you can see that it will work. And there you have it!