Viscosity option doesn't work properly

Hello guys,
I’m trying to get oil or honey-like viscosity for the liquid, but I get always water or alike. The domain is set to a proper size, and I know the formule with which blender calculates viscosity, but the liquid still doesn’t thick enough with any settings I make.


help.blend (1.02 MB)

Hi, sorry for the late reply, but perhaps the following issues might be somewhat related to the viscosity problem.
Maybe give them a try and see if there is any improvement.

There are a few issues with the blend file that you’ve posted:

  • Select the Domain and press [n] to display the Properties Region.
    If you look at the ScaleZ value, you have a negative scale. It’s best
    to apply the scale for the domain, as well as all the fluid sim objects
    by pressing [Ctrl] + [a] > Scale. (ie. Scale X,Y,Z = 1.0)

  • the overall size of your simulation may be causing issues. After I
    applied all the scales, the baked fluid was getting a weird diagonal
    portion of the fluid being “cut off”. To fix this, I would recommend
    scaling everything up by a factor of 10 to avoid any numerical precision

  • You may need to increase the resolution somewhat. Some times having
    too low a resolution doesn’t produce an accurate representation.

Normally, the default Honey viscosity setting works quite well; but you could
try changing the timing settings to make the fluid look more viscous.

While the default fluid simulation allows you to adjust ‘Slip’ amount, if
you wanted to have the fluid appear ‘Sticky’ (for example, adhering to a
curved surface as it flows), you could try fluid particles and utilize
pyroevil’s CubeSurfer python script.