Visibility issue with imported object <SOLVED>

Hi guys. I imported an FBX from character creator, and the boots are rendering outside of the pants for some reason. There’s nothing unusual going on in materials that I can see. And the boots are not physically outside of the pants. Any ideas?

Are they “in front”?
Object properties → Viewport display → in front

No, it’s not a viewport issue. It’s in the actual render. It does the same in rendered view, but not in solid view. The picture is the actual render.

mmm It’s hard to tell like this, I should have a look at it :confused:

I’m going to fiddle with it a bit more, and if I can’t figure it out, I will post it. So far I have determined that it is definitely a material issue. Thanks for your help.

Are you using eevee?

1 Like

Good call! Switching to Cycles fixes the issue.

The pants may have flipped normals.

When you are in Eevee, is the material’s transparency set to alpha blend? This can happen with imported materials and it sometimes causes depth issues.

I would highly suggest the CC3 Blender Tools addon for switching the FBX from CC3 to Blender and back. Almost a one-click-setup.

More info:

  1. Object is very small in size compared to other objects in the scene, so, although it is in the scene near other objects, it can not be seen because it is “infinitely” small. If you focus on the selected object as I mentioned in #1 above (click the ‘F’ key with your mouse pointer over the scene view pane), the object will become visible, and other objects in the scene will become gigantic as a result of focusing on the small object. If this is the case, you must select the object in the PROJECT pane, and adjust its Import Settings: Change the “Scale Factor” (at the top of “Import Settings”), to something much larger than the default 1, say 50. Adjust this value by trial and error. When you change this value, the effect will become immediately noticeable in the scene.
    logo design affordable

Thank you for the replies. I found a simple fix. In materials settings, I switched from alpha blend to alpha clip. Problem solved.