Vista+Blender 2.47+texture mode=lower framerate?

Hi its me again!
Well i just downloaded the newest blender and when i textured a texture to a plain and went into the ge i got 12 frames per second but when i was in solid mode i got my usually 27 fps does anyone out there know how to fix this cause i so don’t want to download blender 2.46 again!

Please and thank you again for your time!

Somebody Please Help Me!lol!!!

I don’t have vista, but frame rates are extremely finicky. I am constantly fighting frame rates, with a quad core and 3 mb of ram. Who knows. The blender GE is not as robust as other engines, in part because it’s a non-compiled engine. The havoc/unreal etc engines need to be compiled, and compiled programs always run faster. My knowledge on this subject is limited, but if you’ve ever played a 3d game on your computer, and it runs fine, and you get a terrible frame rate with just a plane, then you know it’s not your computer. It’s the engine.

Your graphics card may also be the issue. Apparently Blender doesn’t like ATI. I have an nvidia 7100 something, and I can play bioshock, oblivion etc fine, and it struggles with a simple scene.

Check for lots of lights. Lights are always a framerate killer. Also make sure there is not extranious geometry. Of course, as I understand it, vista is a hog. I got new computer with xp on it recently. No vista for me.

well it did’n do that between version 2.25-2.46 on me thats why i was asking

Are you sure you didn’t use a very large texture, or put something
other than the plane in, that could slow the thing down?

Im running vista, and also got 2.47 today. I havent experienced any issues like that.

i’m sure cause i did the same thing in 2.45 and 2.46 and got 27 fps but in 2.47 i got 12!i show picture in min.

heres 2 pictures the lower frame rate is from 2.47 and the higher one is from 2.46
same texture and everything!
the reason 1 is bigger is becaue i zoomed in closer

Attachments



That is odd. If that’s the same everything - no mods whatsoever, just a new op system…damn.

Why even use the BGE in 2.47? The Apricot BGE has the best stuff, plus you know it works because of the Apricot project.

It works, but it is a bit buggy. I have every confidence that they will fix everything for the next release.

Vista is a BIG problem. Use Linux

blender seems exceptionally stupid on any windows platform to me for some reason

This isn’t a Vista problem or I’d be having it too. However, it could well be some kind of bug that was created while fixing other problems… anyway, if possible I’d recommend using Apricot builds too. They are slightly buggy, but they’re also extremely powerful.

@oblenob: You 'nix peeps really are insufferable. Linux is a brilliant os, but you guys are so snobby/rude that it certainly doesn’t attract users.

well the reason i don’t use the apricot build is because my current graphic card tore up and sence i was only useing apricot for monkey rampage! i don’t use it anymore(at least untill i get a new graphic card)

Overhead metric has tripled between the two. A place to start might be in figuring out exactly what “Overhead” is a measure of (besides the obvious). And has that part of the Blender GE changed.

If the only change is 2.46 to 2.47 then I’d say it’s very likely a change in Blender. True 2.47 is a bug fix release but if 2.46 performs better for this purpose, then why not have both versions installed on you computer?

i do have both installed on my laptop but i can’t use 2.47 cause of the texture problem but in 2.47 i LOVE the new logic brick setup except for the state thing what does that do?

I’ll go replace it by the 2.46 then.
What’s the new logic thing other than the state one?
Edit: I have heard that Blender has trouble with ATI cards but an awesome and cheap for it’s quality one, that can play Oblivion with HDR, full realtime soft shadows and antialiasing SMOOTH, is the ATI HD 4850, and the 4870. The first one’s around $160 on the net. A similar quality nVidia video card’s around $280 on the net.

well there a swerve thing in the motion accurator thtere a couple more i can’t seem to remeber

I am running Vista 32bit and blender 2.47 with an Intel graphics card and I did that test, my frame rate seems to be normal. Try changing your OpenGL settings in blender, or resetting to default your graphics card settings.