Visual C++ 2008 Redistributable not installing

I’ve been trying to use the new version of Blender(2.48) but it says that I need Visual C++ 2008 Redistributable in order to run it. So I followed the link on the Blender website to download and install. But every time I try to do it I get an error message and it won’t install, which prevents me from using Blender. I have been using Blender for a very long time and I really do enjoy using this great program, so it makes me upset that I can’t use it. If anyone could help me I would greatly appreciate it. I’ve attached a screenshot of the error message I recieve when installing the required software.

NOTE: I’ve made sure that the version I intalled is the correct one(x86) for my computer is 32bit.

Attachments


Restart computer.

Yeah. That worked for me. But I had trouble installing the new python. I installed 2.6 but Blender doesn’t know where it is.

Sidenote, get Firefox or Opera. (My personal favorite is Firefox.)

I’ve tried all of your suggestions but none of them are working. I guess I should consider finding another 3d modeling program since Blender doesn’t work for me anymore:(

Does the plain 2008 c++ redistributable work? (not the sp1 one, which is what your window shows.)

I don’t know for sure, but closing unused tabs in your browser and shutting down non essential background applications might help. Maybe do a search for the error code in the message.

Azmisov, did you correct your path statement to reflect the changes?

Yes, I also tried the plain redistributable and I tried to install it with no other programs running. I also searched for a solution with the error code but there was no documentation anywhere about this error. I’ve been trying to solve this problem ever since 2.48 came out and I finally decided to seek for an answer here. Well, I really do like Blender a lot, so if I can’t get 2.48 to work I’ll just use 2.47 for now and wait for 2.49 or 2.50.

you should install 2.5.2 python not the latest 2.6, because blender 2.48 was build with the former.

Problem solved!!! The new version of Blender(2.48a) doesn’t need the Visual C++ program. Yes! Now I can finally experiment with it’s new game engine features!!!