Volume Render in 2.5...

I’m not sure about your light set up.

But it looks like you need more lighting variation and shadowing, try playing around with the lighting. I would suggest a light/ medium blue lamp above the clouds, as well as the sun lamp (A very faint yellow/ orange), Then I would put a very very faint blue lamp under the clouds, along with some other various coloured lamps (Green, brown) to mimic the light reflection from the earth. I would then use scattering with the volumetrics to achieve some volumetric lighting.

Yes, I am just cueing up getting ready to render the flythrough, I have a tried a couple flythrough renders in the past, but wasn’t happy enough with the results. thanks for the comment, I’ll eliminate the background clouds and fix up the ground now that I’m happier with the main attraction. I agree I could spend more time lighting the clouds better I will try that too. Up to this point I have been working ont he look and shape.

Now your getting it! :slight_smile: Look forward to see your progress

I was just reviewing this point density / particle cloud tutorial on vimeo. http://www.vimeo.com/7177831 You’ll notice he also has one on node based clouds, which I tried recently, with good results. They are both quite good tutorials, I thought.

So I whipped this animation together in an hour or two before I left on vacation and hit render. I used the exact settings in the above posts. It took my quad about a week to render this. If you stop at inidividual frames it looks pretty cool, but the flickering is pretty annoying. I think it’s because I turned the sun up to higher than one, but need to test this theory out. Does anyone know what causes the flicker in volumes?


Cheers! still working.

Ok, since this a work in progress I created an entire thread for a bug I encountered and Matt Ebb himself (the man) cleared it up for me. You can read the entire blog to get the details here:


Or just read what Matt said here:

Hi there,

If you’re using an asymmetry value different to 0.0, that will cause
problems when using light cache. Known issue, just haven’t had the
time to look into it deeply yet (busy with 2.5 stuff). Possible
workarounds for this are to just use 0.0 asymmetry or disable light



I am going to start rerendering my flythrough in the garage without light cache, so it will be a lot slower, but I’ll post it here when I’m done.

Could you post your .blend file so i can look at it? I’m quite interested in this

Here is a quick .blend that has exactly what I’m doing set up in it attached below.I used a normal cloud texture in this one instead of a nodes based one like I do in the animation but everything else is the same. I don’t want to post the big one because it is 289 megs with the particles baked in. I will post the whole thing if freeing the bake will make it a manageable size tonight.


volumeFlickerTest.blend (104 KB)

Ok so you need 15700 or newer for these, but I had to redo the .blend because my old files crash blender now when you open them so I rebuilt these files from scratch and played with the settings. These are slightly cartoony, but I was going for mood.


DarkCloud.blend (131 KB)

One more daytime shot… remember 15700 or newer…


LIghtCloud.blend (135 KB)

Very nice NRK… thank you very much for your work. I’ve also been messing with cloud volumes and have come up with the attached images…

I also tried animation and got the flickering and now I know how to address it!



You’ve caught the bug! I’ve been waiting for someone to catch it. Way to go my friend… I really like the evening clouds… check this out… I’m having more fun than a kitten following a leaky cow!


DarkCloudLightning.blend (152 KB)

Cool, I’m glad I found the cloud thread :slight_smile:

Here’s what I’m working on… 140,000 vertices in two domains. I’ve found the flickering goes away if you increase the size of the light cache.

These clouds are too much fun – I could easily blow a few more weeks playing around in them! Alas I have to come back down to earth. :slight_smile:


Now tha one is very impressive, is it just a generic displace or is some sculpting involved? My volumetric tries ended with a sphere…

Wow… Well Done! I agree it’s awesome! Can you share your material settings and lighting? Or post a .blend with those items in it? It looks like the vignetting is post processed… am I right? So you did that without particles? That’s a lot of modelling if you so… anyway… well done!

Wow, bensyverson, that looks very realistic. any chance that you could post the .blend?

Thanks guys! I’ll post a blend soon. My modeling process is something like this.

  1. Sculpt the basic cloud shape
  2. Apply a particle system with 10000 particles, turn off Gravity and Normal Emission, change start and end to frame 1
  3. Create a new “Clouds” Texture (Depth 3, Noise: Hard, Size varies with size of the mesh, I used 4.0)
  4. Use the texture in a Texture Force Field
  5. Animate the particle system. It should blow apart completely within about 5 frames. Usually frame 2 is pretty good. You want to keep the shape of your sculpt, while letting the edges get blown out a little.
  6. Export as XYZ, re-import as XYZ to “freeze” the particle vertexes on the desired frame

I did that about 12 times, building up a library of individual clouds. Then I assembled them into a cloudscape.

Volume material settings: Density scale: 0.5, Scattering: 3.2, Emission: 0.1 (bluish). Point Density texture settings: mostly default, but remember to set Coordinates to Global. Turbulence: Voroni F2-F1, Depth: 3.

Lighting: One reddish sun lamp (brightness 3.3) and one bluish hemi lamp (brightness 2.0)

Post processing: none – I just added a background (sky) image

Excellent… THANK YOU! I am going to try that!

I forgot to mention… When building the cloudscape, I spent a lot of time rotating around and trying to imagine it prior to rendering… Then I made a copy of the .blend, and Joined all the point cloud objects together into one mesh per domain. That way, each domain had only one Point Density texture applied, which speeds up rendering.

Also, domains do weird things when they overlap, so make sure they don’t touch!

could anyone help me a little?
I can’t get the texture force field to work, do i only have to create a texture for the emitting object and select texture in the particle systems force field setting? Because that doesn’t seem to work.

And i also wonder how to do the “Export as XYZ”?