'Volume' Tab Disappearing?

Quite simply, the Volume tab isn’t there on some .blend files.
Here’s an example:

With Volume option: https://gyazo.com/d7b02dbf58717206b43619922fd3b9fa
Without Volume option: https://gyazo.com/d7b02dbf58717206b43619922fd3b9fa

I’m not sure if this is a bug, or me being stupid.
So bacially, when I start the .blend file, it’s usually not there. But then it spontaneously appears out of random during editing. Sometime I have to close out of Blender, sometimes I have to play around with tabs. I’m obviously very confused by this. lol
Anyways, all help is greatly appreciated!

The two images you link to both show the volume option so not sure their purpose. If you want to supply an example please use one that clearly shows what you are talking about

I assume the Volume option appears when you enable the use of nodes for the world material either in the node editor or in the world settings (when using cycles as the renderer)