Volumetric Clouds

Hello Support
I am new here though I have been a Blender user and supporter for about 6 years most of which were using Blender version 1.78 because I was limited to my PC performance.
I recently purchased a new PC over $1200 mainly so I could use the latest Blender version 2.83 and found I had a huge hurdle to overcome learning Blender all over again. I find some new features complicated or buggy such as the “Collections” in the Hierarchy, but that is not what my topic is about.

Though I should mention from the start of using 2.83 I ran into problems with BlenderGuru’s “Donut Tutorial” using Displacement to get a realistic bump texture on the donut. Blender would not render the donut at all in Cycles. I was discouraged to say the least.
Currently I have been working on an animation for a story that I would like to use in an augmented reality app.
I needed to create a nuclear explosion and approached the concept using the “Smoke/Fluid” simulator which would not render as well. I later discovered I could fake a mushroom cloud using Volumetric Clouds created with Metaballs. It worked but I was not satisfied with the animation and decided to restart the construction of the mushroom cloud with another method I discovered in a tutorial entitled “Make Super Satisfying Animation in Blender Eevee” Which shows a Torus like object twisting inside out sort of speak.

I thought I could use this method with volumetric clouds to create the rolling mushroom cloud effect without Metaballs.
It actually worked and I was super pleased with how things were turning out, until I tried to add similar effect with smoke rings that you may see associated with mushroom clouds. Suddenly my mushroom cloud that was working great previously, now looked like a giant foggy cube, and I can not get it back the way it was. I had saved my file after I created the smoke rings and overwrote the previous file before I created the smoke rings, so no returning to better the situation.
I know I have seen tutorials explaining the issues with creating volumetric clouds with shapes and they result in rendering as cubes, though for some reason I had got around that obstacle, for a few days until I created the smoke rings. I tried everything from deleting the smoke rings to re creating the nodes for the mushroom cloud and it still does not give me any satisfying results.
I have spent about 2 or 3 weeks on this animation and all is lost. What could be the issue?

I would suggest starting with this channel as it has some good simulation info . https://m.youtube.com/c/Iridesium/featured?disable_polymer=true&itct=CDQQ8JMBGAAiEwjqgte1sNXsAhWuQEwIHVklCEw%3D

But if you have an example or blend file you can post that would help

I can post a blend file here? How?
I can post some images I rendered also to show what results I was getting.

Oh Ya! I like this guys stuff. I did start with that channel and realized I could not render smoke sims for some reason. I started to question 2.83 at that point…well I questioned 2.83 when I could not render the donut from BlenderGuru’s tutorial

There is a upload button for files or you can just drag and drop.

I wouldn’t recommnend anyone to start with BlenderGuru.

This video is a good start: https://youtu.be/1jHUY3qoBu8

Thank You.
I have actually seen that video recently. Good video.
Like I say I have been using Blender for at least 6 years, but just recently as of this spring and summer switched from 1.78 to 2.83. Yes a bit of a leap, but I have previous Blender experience.
Is 2.83 full of glitches? I was thinking of trying 2.9 but was not sure.

I received a message “Sorry new users can not upload files”

You can try an external file transfer service

You can use dropbox or google drive etc. But I currently use 2.90.1 and I have few issues and I rarely had issues with 2.83. The problem with tutorials is that unless you get the exact same version somethings may have changed. from what I can tell 2.90.1 is ok for simulations.

Ya that is what I have noticed. The program versions are so different now the tutorials are bogus.
Some annoying issues I am experiencing with Hierarchy and Collections is selecting objects and it is driving me nuts.
Example 1: I have a collection with several objects in it. I select the collection yet none of the objects are selected in the collection. I right click and select objects, all the objects are now highlighted orange yet they are not selected as I get a warning that says, “No Objects selected”.

Example 2: I select collection and delete it yet objects in that collection still exist.

Example 3 Sometimes I create a new object and it is put in a collection. Which one? I will have to locate it…Gee its a the bottom of a really big collection I created for Cell Fracture and I have to manually scroll through hundreds of objects to reach the new object that I did not want in that collection in the first place. It is a major pain!
I have had things working good then something suddenly fails to work like a shader and I delete the shader and create a new one of the exact same type and problem fixed. WTF??

Example 1. Solution is to right click the collection and press s on keyboard and then make sure to middle button mouse in the viewport to move them.

  1. Right click and use delete heiarchy on the collection

  2. Make sure to select the collection you wabt tHe object to go into.

I have not expereinced shader issues related to blender.

The key to using blender efficiently is to know the keyboard shortcut patterns and to always iterate your files.

Thanks, though it seems more complicated then it used to be wouldn’t you agree? More clicking and actions = more complicated. Remeber when you could animate every aspect of Blender, including the Viewport Visibility, the Render Visibility, etc. Why did they cut that out of Blender?

Another question please and thank you for your help: “The Ocean Modifier” (My first time using Ocean Mod) When done with settings do you need to Bake the animation? Or does it stay the way it is until you are finished rendering animation? My project is 2 minutes long, with audio track that is waiting to be added in video editor.

Blender has changed in the last few years with a ton of added functionality so with that comes complication. All creative aplications have thier quirks but with blender there is usually a work around. Not to mention if you learn to code in python you can try to change it. I prefer the work around or alot of add ons for blender are created for that reason.

You can choose to bake the animation if you want or leave it till end. I would suggest a 50 frame render test to check.

Thank you Peter
Yes I would like to learn Python, and actually set out to learn it a few years back, but was distracted by other projects and life to say the least. I was really involved in the game engine (Logic Bricks) and was creating some cool stuff, and I had some good ideas for the UI to make the logic bricks less cumbersome as they can be when too many are used. Though the logic bricks were kind of limited, unless you could accompany them with Python code, and expressions, which is why I set out to learn Python.
Yes I have been rendering segments of my animation, like you suggested, 50 or more frames at a low resolution to test the flow or lighting, and I have gone back to using the metaballs and volumetrics for cloud formations, and it seems to be working out.
I will post a pic or perhaps the entire animation when I am finished.
Thanks