Volumetric in EEVEE doesn't work

(Veezen) #1

I get newest version from 18.11.2018 of Blender 2.8 to test new things and finally make some renders because normal maps were finally fixed - thanks Clément :slight_smile:

But I find out new problem with volumetric option which is weird because as far I remember everything worked fine months ago when I tested it.


I was confused so I watched this video and made each step the same - results are different, volume box (which is connect as in video, to volume material output) is completly transparent. Any sugestion for that issue? Maybe something were changed along the last few month of development and now we use this in different way?

1 Like

(Renzatic) #2

I’ve never been able to get volumetrics to work as an object shader in Eevee. Dunno if it’s a planned feature that has yet to be implemented, or just something Eevee won’t be capable of in 2.8, but I’ve only ever been able to use volumetrics attached to a world output.

0 Likes

(• I don't speak English "by default", so... ) #3

It should work, if it’s not, is a bug.

0 Likes

(English is not my native language) #4

You always share your problematic .blend file so that others can analyze the problem.
http://pasteall.org/blend/index.php?id=50736

Edit:
I do not have time to watch the tutorial. You are using Distribution=1. Is this explained in this way in the tutorial?

0 Likes

(Robert MacIntosh) #5

Volumetrics haven’t worked for me, either. At best the bounding box will have a volumetric effect. If i add textures to a color node for the volumetric color it will go transparent. Been that way for a long time. cycles in 2.8 works fine. What system are you on? I’m on osx. I’ve seen other tutorial on volumetric and theirs are working.

1 Like

(CarlG) #6

Yeah I got bounding box coverage for a pyramid shape the only time I tried it.

1 Like

(English is not my native language) #7

I’m on Linux, GTX 960.
Does the file I have shared above work for you in new 2.8 build when you open the file and turn to Eevee Rendered mode?

By the way, in the case of @Veezen, I’m pretty sure the problem may be due to Distribution=1 configuration he used.

0 Likes

(Robert MacIntosh) #8

the first image is how the file is. Seems fine but the volumetric on suzanne to the left only shows the bounding box. The second image, the cube i added a mix node with a texture factoring it and the volume disappears. And the third is 2.8 cycles and it works like a charm.

0 Likes

(English is not my native language) #9

Volumetrics for objects has not been implemented in Eevee and there are no plans to implement it for now, as far as I understand.
About that node setup, I have no idea
Edit:
For the second image I get colored volume if spot beam of light hits the cube
http://pasteall.org/blend/index.php?id=50746

0 Likes

(Robert MacIntosh) #10

thanks for the info. I was just wondering if it’s an osx problem exclusively on the textured volumentrics

0 Likes

(English is not my native language) #11

Sorry, I edited my previous message and shared a blend file while you wrote. Is that file working for you on Eevee?

0 Likes

(Robert MacIntosh) #12

Here it is and no, it’s not. I’ve tried just about every variation and nothing. When i get a new daily build i’ll try it out and see but no luck yet.

0 Likes

(Veezen) #13

So how to use Volumetric without using object?

0 Likes

(CarlG) #14

Oh, ok, wasn’t aware of that. So I guess it’s only for “scene fog” related things where you cover up everything in a bounding volume.

Late edit: This is a Cycles crop of what I couldn’t do in Eevee. It was just a test, nothing important.
volumelight

0 Likes

(English is not my native language) #15

With volumetrics in objects I was referring to that in Eevee it is still not possible to achieve the above example with monkey/suzanne in Cycles. In Eevee you can use a Cube like in the tutorial. Or configure volume nodes in World nodes.

@macro, Yes, you try new build. Or maybe a problem that only happens with your hardware/OS/drivers.

0 Likes

(English is not my native language) #16

There is a Custom Distance item in lamp settings. You see if it is useful to achieve the effect you are looking for.
By the way, I think it would also be useful to be able to crop from the origin of Spot lamp, so that the beam of light does not start so sharp from the cone’s height.

0 Likes

(qomolangma) #17

By now, you can render volumetric effect of world using principle volumetric shader node, but you can’t render smoke volumetric normally.

1 Like

(mediaklan) #18

I’ve just come across this issue : well, I don’t exactly know if it’s the same but I got the same transparent box after connecting a principled volume to the volume of the material output node. Now the box stays transparent as long as I have some distance from the box in my perspective view. If I get close enough (like, real close), I’m able to see the volumetric effect on the box.
And it’s the same for the camera : I have to put it really close to the box to get the volumetric effect in my render, and the camera clip end value is not helping.
EDIT : - -’ Nevermind (and sorry). I’ve just discovered the clip start/end values for the volumetrics … in the volumetric settings.

0 Likes

(Yauheni Vasiutsinski) #19

Hey Veezen! For me it worked when I’ve switched from Perspective mode into Ortho. Maybe it’ll help you to define the direction of the problem.

0 Likes

(PhiliChez) #20

Deleting the contents of the density attribute text field on the principled volumetric node has worked for me.

3 Likes