Volumetric in EEVEE doesn't work

I had the same problem, the End distance was set too large for the scene in render settings. I made it smaller and got the regular result.

Bro, i just sign up this website to say thank you, it worked bro.

This should be working for some days now in new buildbot builds:
https://developer.blender.org/rB8d3af588a23734c59f22a6feebe2d10f1a281875
Edit:
Sorry, I thought it was this other thread:
https://blenderartists.org/t/principled-volume-eevee-not-working-after-april-5/

Lol, you’re welcome, but it was only thanks to another hero in some youtube comments that saved me. I had enough frustration and then relief that I just had to share it here where I had the most hope of finding the solution the day before.

1 Like

thank you , this helped me !

are there any Mac egpu users, or iMac pro users with a Vega 64?

volumetric density textures were broken on my system for a while earlier in the year, then worked ok, and now for the past month or so of builds have been broken again on the Vega 64. ironically they display ok on the weaker 560x inside my MacBook Pro. just curious if others have the issue and its worth bug reporting?

weirdly I’ve also found additive eevee materials work on older builds but seemed to break around the same time the volumetric issues cropped up