volumetric lighting problem

Hi. I have a scene with a brick wall (made from individual cubes) and an opening with a cross tie (is that the right word?) inside it. Outside I have a volumetric lamp casting through the window onto the contents of the room. The problem is it seems the wall does not effect the light at all. The cross tie and the contents do, but the light seems to pass right through it the wall. :-?

In the bricks’ material I have Traceable enabeled. Raytraced in the Render Buttons is also enabeled. How can I fix this? Thanks.

-Laurifer

Can you post an image of what you are getting ?

It would make it easier to figure out what is going on.

Simon

  1. use a spotlight
  2. in the “Shadow and Spot” panel select Buf. Shadow and Halo
  3. Set the Halo Step value to about 8 to start. Note that this option is not available unless the above Buf. Shadow has been selected.
  4. render – you may have to adjust the halo step value to suit. No ray-tracing involved :smiley:

**edit – image added **
http://members.shaw.ca/rjplus/halostep.jpg

Hope this helps,
GreyBeard

Thanks for your replies. Here are the settings I have for my spot light:

Buff shadow on, Halo on, HaloInt 1, Samples 16, and Step 12. I need a really good quality light, so I would like to leave those up high.

Here is an image of what I am getting (sorry it has to be Geocities, I can’t access my Photobucket account for some reason):

http://www.geocities.com/laurifer3d/volumetric_light.jpg

You can see that the light passes through the wall, unlike in your image, GreyBeard.

-Laurifer

There’s a box in the spot options that make the shadow in the halo visible, try messing with typing in values in the boxes.

You appear to have uncovered a bug
clipsta = 8.0, clipend = 30 should work but doesn’t
http://members.shaw.ca/rjplus/halo1.jpg
http://members.shaw.ca/rjplus/halo2.jpg

change clipsta to 2 works

http://members.shaw.ca/rjplus/halo3.jpg
http://members.shaw.ca/rjplus/halo4.jpg

The clip start and end seem to be behaving strangely. Try setting clipsta to 1 or .1 and see what happens.
By the way check the docs about the step value, if I remember correctly, 1=highest quality, 12=lowest, 0=off.

If none of the above works – post the blend and I’ll look at it.

GreyBeard

Ah! :smiley:

Much better! Origionally I had the ClipSta set to whatever the default is (.5?), but then I found the lighting tutorial on blender3d.com in the tutorials section. It said there to turn the ClipSta up. I guess that was working with an older version of Blender. :-?

Is there a place I should report this bug?

Thanks GreyBeard!

-Laurifer

You can report the bug at www.blender.org on the Bug Tracker (menu on the left under Blender)

Happy blending,
GreyBeard