Volumetric procedural clouds at night problem (during the day they are ok)

Hi, guys,

Blender asset addon includes a free Volumetric procedural cloud. It looks very good in the daytime. But it looks black at night.

I use Blender addon “Physical Atmosphere and Starlight”. During the day, the sun is White. During the evening the sun is Yellow. During the night, the sun is Black. The color of the sun is controlled by rotating the sun from day to night cycles.

The procedural volumetric clouds receive this base color from the sun. I guess there are two solutions:

  1. Change the shader of the clouds. Not sure how to do it.
    This means that at night the sun gives the clouds a Black color. Is it possible to set up a mixed color? The first color is white. The second color is the color of the sun. I have control of both colors. Here’s the shader now:

2nd method. Add additional sun.
I have found another workaround, I have added a second fake sun which gives the clouds a White color during the day. But this sun adds brightness to the whole scene, not only the clouds.
Is there a way to restrict objects from inheriting the brightness and color from the Second fake sun?

3rd method.
Edit world shader?

Thanks for the advice in advance!

The number of volumetric bounces in the Light Paths tab of the Render panel has a huge effect on how volumes look.

If you haven’t changed them from default - the likelyhood is they’ll be set to zero and might be why your clouds look black, there isn’t enough scattering going on.

I have found somewhere between 5 and 10 to be a good compromise between speed and accuracy. I’d see if that makes a difference first.

Hi Moony,

Render panel >> Volumetrics >> Volumetric lightning >> “Light clamping” does no effect to the clouds.
But I found another way to make them shine. Used “Anisotropy” and Density values in Principled volume node. That worked.

I have also learned that scaling volumetric does not help, the quality stays the same. The only quality I could increase is by doing:
Render panel >> Volumetrics >> “Samples” and “Tile size” help

I expected more quality from volumetric clouds. I hope to find a solution. Perhaps I should do image clouds instead.

p.s. Thanks for the help so much! Really appreciated!

Not sure I helped all that much - but no problem :slight_smile:

Just one thing - my advice was based on the assumption you were using Cycles, but from your solution you must be using Eevee since the setting you changed is in the Eevee render panel, not the Cycles one.

It might be worth mentioning which render engine you are using next time as the solutions can be very different.

Yes, you are correct, I’m so new to rendering that I still don’t understand all that much! Now I do understand how different settings are :). Thanks anyways!

Now I understood that if I want quality for volumetric in Eevee, I need to put upsampling as high as possible. Tried it yesterday, and the rendering time was too long, 7 days for a 7-minute video on my computer :). I turned it off.