Voodoo Shape Keys

I’m having difficulty animating shape keys.

I started my project in 2.49 where I made a few shape keys for two different meshes. I’ve switched over to 2.53 where I’ve added several more meshes and shape keys to two of them.

When I set a shape key on one of the old meshes (in object mode) and do a single-frame render, the shape change does not appear. HOWEVER, if I make the changes in the dopesheet for an animation, they appear fine and dandy.

Conversely, shape key changes on the new meshes WILL show up on single-frame renders BUT no sliders appear for them in the dopesheet, so they can’t be animated!

In the outliner hierarchy, its pretty clear that the two animatable meshes have an “Animation” branch beneath them with reference to a “ConvData_Action”, whereas the UNanimatable meshes do have a key heading, but nothing underneath. (I don’t know what any of this means, but I’m sure the problem is in there somewhere!)

Please, if someone could help I would be very grateful!

I sort of solved the problem, I think. Although I don’t know why, and the fixed shape key sliders are showing up in a yucky yellow colour unlike the others, which tells me my fix is still funky somehow.

In the Dopesheet, I switched to Shape Key Editor mode. The missing shape keys showed up there. I gave each of them in turn an adjustment up and down, after which, hey presto! They showed up in the dopesheet! ONLY the ones I fiddled with though, the others remained invisible. Anyway, I fiddled with them all, so they are all visible now but a weird colour which kind of gives me the creeps.

Anyway, if anyone knows why I needed this weird workaround, please let me know!

(PS: Thanks to everyone who posts solutions to problems here; it seems every time I run into trouble, this is where I find the solution! This was the first time I couldn’t find a solution already dealt with!)

when you are on the dope sheet you need to change the type to shape key at the bottom to get the sliders

Thanks, Chippy!

The problem is that only the old shape key sliders show up, not the new ones. At least, not until my workaround. I’m going to test everything tonight by doing an animation that employs every single one of the 75 or so shape keys to make sure everything works before continuing.

as far as i know your work around is how you are supposed to do it unless you use a driver.

But I don’t understand why I had to do this with some, but others were there automatically. And the new ones do appear a different colour. I think it might have to do with the first ones having been created in 2.49.

Oh well, it works! Thanks again!